Bookmark changes the Reader View Character Encoding

RESOLVED DUPLICATE of bug 1176827

Status

()

RESOLVED DUPLICATE of bug 1176827
3 years ago
2 years ago

People

(Reporter: rtfranco, Unassigned)

Tracking

38 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Build identifier: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0


If the user Bookmark a page in the Reader View Mode and then opens this bookmark, strange characters appear.


Steps to reproduce:
1. Visit this link: [http://www.planalto.gov.br/ccivil_03/constituicao/constituicaocompilado.htm]
2. Check the Character Encoding (View -> Character Encoding). 
3. Select the Reader View Mode
4. Bookmark the page while you're still in the Reader View Mode.
5. Open the page Bookmak (the bookmark will open the link in the Reader View Mode)
6. Observe that some characters change to strange displayed characters ('?' ones)
7. Exit the Reader View mode
8. Check the Character Encoding again (View -> Character Encoding). Now it's 'Unicode'


Actual results:

At step 2, the Character Encoding says 'Western'


At step 8, strange characters appear the Character Encoding says 'Unicode'

Updated

3 years ago
Component: Bookmarks & History → Reader Mode
Product: Firefox → Toolkit

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1176827
You need to log in before you can comment on or make changes to this bug.