M097 Trunk Mozilla dies immediately [@ libc.so.6 - nsImageGTK::~nsImageGTK][@ nsCOMPtr_base::~nsCOMPtr_base]

RESOLVED DUPLICATE of bug 92577

Status

Core Graveyard
GFX
--
critical
RESOLVED DUPLICATE of bug 92577
16 years ago
9 years ago

People

(Reporter: borekl, Assigned: Kevin McCluskey (gone))

Tracking

({crash, topcrash})

Trunk
mozilla1.0
x86
Linux
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20011231
BuildID:    2001123113

Long standing bug. On the www.isdn.cz site clicking any link (ie. news article)
causes Mozilla to crash. Even exiting the site often causes a crash. This bug
exists for very long time -- I tried many builds and it affects all of them.

Reproducible: Always
Steps to Reproduce:
1.Just go to the link indicated; alternatively go to www.isdn.cz and click any
link to "article" (in the main area of the site)


Actual Results:  Mozilla crashes immediately

Expected Results:  Render the page correctly and without crashing

Comment 1

16 years ago
Crash on Linux 2001121921, talkback TB1135117Y.

Comment 2

16 years ago
wfm using build 2002010103 on Win2k.

Stephen, can you retreive Talkback data please (TB1135117Y) ?
Keywords: crash

Comment 3

16 years ago
WFM 2002010103/WinNT4

Comment 4

16 years ago
This site either freezes or crahes me: Mozilla 0.9.7 (2001122108) Linux
Sorry, I'm not sure why there's no data attached to that Talkback report. 
Please cc me if you get another crash/ID.  Thanks.

Comment 6

16 years ago
WFM 2002010203/Win98 SR2

Comment 7

16 years ago
Yet another talkback: TB1159266M, Linux 2002010121. I went from the article
cid=3475 back to the main page and to another article before the crash occurred.

Comment 8

16 years ago
rendering. ->compositor.

(talkback database is a bit behind. here's the 2 stack traces)

libX11.so.6 + 0x2c876 (0x403b7876)
libgdk-1.2.so.0 + 0x24574 (0x40342574)
nsGCCache::GetGC()
nsRenderingContextGTK::UpdateGC()
nsRenderingContextGTK::FillRect()
nsRenderingContextGTK::FillRect()
nsCSSRendering::PaintBackground()
nsHTMLContainerFrame::Paint()
CanvasFrame::Paint()
PresShell::Paint()
nsView::Paint()
nsViewManager::RenderDisplayListElement()
nsViewManager::RenderViews()
nsViewManager::Refresh()
nsViewManager::DispatchEvent()
HandleEvent()
nsWidget::DispatchEvent()
nsWidget::DispatchWindowEvent()
nsWindow::DoPaint()
nsWindow::Update()
nsWindow::UpdateIdle()
libglib-1.2.so.0 + 0x112f2 (0x403652f2)
libglib-1.2.so.0 + 0x102d9 (0x403642d9)
libglib-1.2.so.0 + 0x108e3 (0x403648e3)
libglib-1.2.so.0 + 0x10a7c (0x40364a7c)
libgtk-1.2.so.0 + 0x8dd97 (0x40287d97)
nsAppShell::Run()
nsAppShellService::Run()
main1()
main()
libc.so.6 + 0x18a42 (0x40461a42)

and

nsCOMPtr_base::~nsCOMPtr_base()
imgContainer::DoComposite()
imgContainer::Notify()
nsTimerImpl::Process()
handleMyEvent()
PL_HandleEvent()
PL_ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
event_processor_callback()
our_gdk_io_invoke()
libglib-1.2.so.0 + 0xec10 (0x40367c10)
libglib-1.2.so.0 + 0x102d9 (0x403692d9)
libglib-1.2.so.0 + 0x108e3 (0x403698e3)
libglib-1.2.so.0 + 0x10a7c (0x40369a7c)
libgtk-1.2.so.0 + 0x8dd97 (0x4028cd97)
nsAppShell::Run()
nsAppShellService::Run()
main1()
main()
libc.so.6 + 0x18a42 (0x40466a42) 
Assignee: asa → kmcclusk
Status: UNCONFIRMED → NEW
Component: Browser-General → Compositor
Ever confirmed: true
QA Contact: doronr → petersen

Updated

16 years ago
Keywords: topcrash
Summary: Mozilla dies immediately → M097 Trunk Mozilla dies immediately [@ libc.so.6 | nsCOMPtr_base::~nsCOMPtr_base | nsImageGTK::~nsImageGTK]

Comment 9

16 years ago
*** Bug 118767 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
Created attachment 63983 [details]
Stacks from bug 118767

I was reproducing the same crash in bug 118767. Attaching my stacks.
(Assignee)

Updated

16 years ago
Target Milestone: --- → mozilla0.9.9

Updated

16 years ago
Summary: M097 Trunk Mozilla dies immediately [@ libc.so.6 | nsCOMPtr_base::~nsCOMPtr_base | nsImageGTK::~nsImageGTK] → M097 Trunk Mozilla dies immediately [@ libc.so.6 - nsImageGTK::~nsImageGTK][@ nsCOMPtr_base::~nsCOMPtr_base]

Comment 11

16 years ago
Created attachment 67591 [details]
File that triggers an NS_ENSURE_TRUE failure.

This warning comes out on the console most of the time when browsing
http://www.isdn.cz:

WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file nsHTMLDocument.cpp, line
395

rv contains the value 3253927938 (dec).

Generally the browser crashes after that in a random place it seems like. The
attached file contains a (small) subset of the code from www.isdn.cz which
triggers the NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) warning. I can't get the browser
to crash on this attachment though. Could it be a pointer overwritten somewhere
considering the crashes in very different places?
(Assignee)

Comment 12

16 years ago
Marking nsbeta1+
Keywords: nsbeta1+

Comment 13

16 years ago
Kevin:  There's another bug on "random" crashes experience at www.isdn.cs - bug
92577 .  All the crashes show the libc.so.6 stack signature, but the stack
traces are all different.  Is this bug perhaps a dup of that one?
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0
(Assignee)

Comment 14

16 years ago

*** This bug has been marked as a duplicate of 92577 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
Crash Signature: [@ libc.so.6 - nsImageGTK::~nsImageGTK] [@ nsCOMPtr_base::~nsCOMPtr_base]
You need to log in before you can comment on or make changes to this bug.