Closed Bug 1177091 Opened 9 years ago Closed 9 years ago

Ugly artifacts when entering video fullscreen with layers.acceleration.force-enabled=true

Categories

(Core :: Graphics, defect)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 1184534

People

(Reporter: bmaris, Unassigned)

References

Details

(Whiteboard: [gfx-noted])

Attachments

(2 files)

Affected builds:
- latest Aurora 40.0a2 (from 2015-06-24)

Affected OS`s:
- Ubuntu 12.04 x32 (Graphics: AMD Radeon HD6450)

Preconditions: enable off-main-thread compositing - via about:config, set to true (if not already set) the following preferences:
layers.acceleration.force-enabled
layers.acceleration.draw-fps
layers.offmainthreadcomposition.animate-transform
layers.offmainthreadcomposition.animate-opacity
layers.async-video.enabled

Steps to reproduce:
1. Launch Developer Edition.
2. Visit a video (eg: youtube, vimeo)
3. Enter the video in fullscreen

Expected results: No artifacts are displayed during video transition to fullscreen.

Actual results: Some artifacts can be seen during video transition to fullscreen.

Notes:
- This behavior does not occur with OMTC disabled.
- The attached screenshot captured the transition to fullscreen.

Graphics
Adapter Description	X.Org -- Gallium 0.4 on AMD CAICOS
Asynchronous Pan/Zoom	none
Device ID	Gallium 0.4 on AMD CAICOS
Driver Version	3.0 Mesa 9.1.7
GPU Accelerated Windows	1/1 OpenGL (OMTC)
Supports Hardware H264 Decoding	false
Vendor ID	X.Org
WebGL Renderer	X.Org -- Gallium 0.4 on AMD CAICOS
windowLayerManagerRemote	true
AzureCanvasBackend	cairo
AzureContentBackend	cairo
AzureFallbackCanvasBackend	none
AzureSkiaAccelerated	0
Why are you enabling these 2 non existing values?
layers.offmainthreadcomposition.animate-transform
layers.offmainthreadcomposition.animate-opacity

Why are you force enabling layers acceleration?
layers.acceleration.force-enabled



Can you reproduce the issue in Safe Mode[1]?
If yes and you can reproduce the issue in Safe Mode,
can you still reproduce it even with clean new fresh profile without any addons (extensions and plugins)[2]?

You can also try a standard troubleshoot and diagnose procedure[3].

[1] = https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode
[2] = https://support.mozilla.org/kb/refresh-firefox-reset-add-ons-and-settings
[3] = https://support.mozilla.org/kb/troubleshoot-and-diagnose-firefox-problems
Flags: needinfo?(bogdan.maris)
Blocks: ogl-linux-beta
No longer blocks: 722012
Whiteboard: [gfx-noted]
(In reply to Virtual_ManPL [:Virtual] from comment #1)
> Why are you enabling these 2 non existing values?
> layers.offmainthreadcomposition.animate-transform
> layers.offmainthreadcomposition.animate-opacity
> 
> Why are you force enabling layers acceleration?
> layers.acceleration.force-enabled

I used the information from this article before testing.
https://mozillagfx.wordpress.com/2012/10/06/how-to-help-testing-off-main-thread-compositing/
 
> Can you reproduce the issue in Safe Mode[1]?
> If yes and you can reproduce the issue in Safe Mode,
> can you still reproduce it even with clean new fresh profile without any
> addons (extensions and plugins)[2]?
> 
> You can also try a standard troubleshoot and diagnose procedure[3].
> 
> [1] =
> https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode
> [2] =
> https://support.mozilla.org/kb/refresh-firefox-reset-add-ons-and-settings
> [3] =
> https://support.mozilla.org/kb/troubleshoot-and-diagnose-firefox-problems

All my testing was done with fresh new profile.
Flags: needinfo?(bogdan.maris)
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #2)
> (In reply to Virtual_ManPL [:Virtual] from comment #1)
> > Why are you enabling these 2 non existing values?
> > layers.offmainthreadcomposition.animate-transform
> > layers.offmainthreadcomposition.animate-opacity
> > 
> > Why are you force enabling layers acceleration?
> > layers.acceleration.force-enabled
> 
> I used the information from this article before testing.
> https://mozillagfx.wordpress.com/2012/10/06/how-to-help-testing-off-main-
> thread-compositing/
OMTC is enabled by default for a long time, what's more this post is kinda old (October 6, 2012) and outdated (animate-transform & animate-opacity)

(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #2)
> > Can you reproduce the issue in Safe Mode[1]?
> > If yes and you can reproduce the issue in Safe Mode,
> > can you still reproduce it even with clean new fresh profile without any
> > addons (extensions and plugins)[2]?
> > 
> > You can also try a standard troubleshoot and diagnose procedure[3].
> > 
> > [1] =
> > https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode
> > [2] =
> > https://support.mozilla.org/kb/refresh-firefox-reset-add-ons-and-settings
> > [3] =
> > https://support.mozilla.org/kb/troubleshoot-and-diagnose-firefox-problems
> 
> All my testing was done with fresh new profile.

Please redo the test with default not changed preferences in about:config with clean new fresh profile without any addons (extensions and plugins)
Flags: needinfo?(bogdan.maris)
Indeed, I am aware that OMTC is enabled by default for a while now and most probably it will ride the 40 train. 
Since this issue is gfx-noted already and blocking a future implementation, I don't see the point in your request. 
I've already mentioned that is only reproducible following comment's 0 steps, not in any other way.
Flags: needinfo?(bogdan.maris)
Thank you very much for your answers.
Severity: normal → major
Summary: Ugly artifacts when entering video fullscreen → Ugly artifacts when entering video fullscreen with layers.acceleration.force-enabled=true
Version: 40 Branch → Trunk
Yes, this will be one of the blockers for accelerating OMTC on Linux.  We're not quite there yet.
Can you please try the build here and let me know if you can reproduce the issue?

http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/acomminos@mozilla.com-2667306d3467/try-linux/

Thanks!
Flags: needinfo?(bogdan.maris)
See Also: → 1184534
Attached image Screenshot of try build
(In reply to Andrew Comminos [:acomminos] from comment #7)
> Can you please try the build here and let me know if you can reproduce the
> issue?
> 
> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/acomminos@mozilla.
> com-2667306d3467/try-linux/
> 
> Thanks!

This build is unusable after entering the prefs from comment 0
Flags: needinfo?(bogdan.maris)
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #8)
> Created attachment 8636432 [details]
> Screenshot of try build
> 
> (In reply to Andrew Comminos [:acomminos] from comment #7)
> > Can you please try the build here and let me know if you can reproduce the
> > issue?
> > 
> > http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/acomminos@mozilla.
> > com-2667306d3467/try-linux/
> > 
> > Thanks!
> 
> This build is unusable after entering the prefs from comment 0

This is very useful, thanks. It would be great if you could also try this build;

http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/acomminos@mozilla.com-77113368e14a/try-linux64/
Flags: needinfo?(bogdan.maris)
I used this try build on Ubuntu 14.04 64-bit (not 12.04 32-bit where I reproduced this in the first place) under the original machine I reproduced the issue, and also using another machine Ubuntu 14.04 64-bit and 13.10 64-bit. 
The artifacts are no longer there but the screen goes black for a second in transition from normal to fullscreen, this also happens with latest Nightly (+prefs from comment 0).
Without the prefs in latest Nightly the transition is smoother, the black screen vanishes quicker. 

I see that this build is for 64-bit, the issue I reproduced was on 32-bit, don`t know if this has something to do with the results of my testing.
Flags: needinfo?(bogdan.maris) → needinfo?(acomminos)
Thanks. This shouldn't have anything to do with 32 vs. 64 bit, so it looks like we're good.

The 'black screen' is necessary unless we want to flip the back buffer with uninitialized data.
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: needinfo?(acomminos)
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: