Cannot save or update a new contact via activity if it has a picture

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: oteo, Assigned: arcturus)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
STR:
1.Open Dialer application
2.Enter a number in the dialpad
3.Add it to the Agenda and select "Create new contact" or "Add to existing Contact" options.
4.Add a picture to the contact and press "Done" button in order to save it

Actual Result: the contact is not saved, the action does not finish
Expected Result: the contact is saved and added to the Agenda

Note: In case we want to create or update a contact from Contacts application, the issue is not reproduced. It's necessary creating the contact via activity (e.g. from Dialpad, Call Log or SMS applications)

Environmental variables:
flame master (3.0 version)
Build ID: 20150624055939
Gecko: 87e3154
Gaia: eb0d4ae
Platform version: 41.0a1
(Reporter)

Updated

3 years ago
status-b2g-master: --- → affected
(Reporter)

Updated

3 years ago
Blocks: 1175575
I have the feeling it's a regression. QA wanted for a branch check.
Keywords: qawanted
(Reporter)

Comment 2

3 years ago
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #1)
> I have the feeling it's a regression. QA wanted for a branch check.

You are right, I can not reproduce it in 2.2 branch

Environmental variables:
flame master (2.2 version)
Build ID: 20150624051721
Gecko: 8092f0c
Gaia: 1f8981d
Platform version: 27.0
status-b2g-v2.2: --- → unaffected
Keywords: regression
[Blocking Requested - why for this release]: Regression
blocking-b2g: --- → 3.0?
Keywords: qawanted
No longer blocks: 1178646
Comms triage: Broken functionality.
blocking-b2g: 2.5? → 2.5+
(Reporter)

Comment 5

3 years ago
Borja is fixing this issue in the WIP patch included in bug 1175575 so let's wait it lands in master to confirm that the bug is fixed.
M.Angeles, could you check if this is fixed? #new activity has just landed. Thanks!!
Flags: needinfo?(oteo)
(Reporter)

Comment 7

3 years ago
Unfortunately, it's not fixed yet, I am able to reproduce the bug very often.

Anyway, when reporting the bug I didn't include all the consequences of not been able to save the contact from an activity. The worst is that after reproducing the issue you need to kill the application where the activity was launched (in this case, Dialer). 

Here, I include the complete steps and the results BEFORE LANDING bug 1175575

STR:
1.Open Dialer application
2.Enter a number in the dialpad
3.Add it to the Agenda and select "Create new contact" option.
4.Add a picture to the contact and press "Done" button in order to save it (via camera or gallery)

Actual Result: the contact is not saved, the action does not finish
Expected Result: the contact is saved and added to the Agenda

After the fault:
5. Close the create new contact screen, upper-left button (x), to go back to the Dialpad.
6. Again, try to add the entered number in the Dialpad to the Agenda ("Create new contact" option)

Actual Result: Black screen. It’s necessary to kill Dialer application to be able to use it again.

Some Notes: 
* I don't have a reproduction rate, but it's easy to see (specially when attaching a photo from the Camera)
* Sometimes, after attaching the picture and before trying to save the contact, the menu labels stop working. It seems associated to the same bug but perhaps we should open a different bug for this issue.

Environmental variables:
flame master (2.5.0 version)
Build ID: 20150709050821
Gecko: 60fd820
Gaia: b0791fe
Platform version: 42.0a1
Flags: needinfo?(oteo)
(Reporter)

Comment 8

3 years ago
AFTER LANDING bug 1175575, the STR and the results are the same but after step 4, the result has changed (at least the UI)

Actual Result: Now, after landing bug 1175575, the contact is not saved when "Done" button is pressed and before landing bug 1175575, the action didn't finish.

I have included a video with the current behaviour after landing bug 1175575: https://youtu.be/Y1PLorZ2gxI

Environmental variables:
flame master (2.5.0 version)
Build ID: 20150710111855
Gecko: 2c7068c
Gaia: c77dffd
Platform version: 42.0a1
(Reporter)

Comment 9

3 years ago
We have doubts about the builds we are generating in Telefonica, some of us are not reproducing this fault after doing make reset-gaia. For that reason, setting qawanted keyword to confirm if the bug is also seen by QA team. Thanks a lot!
Keywords: qawanted
QA Contact: ktucker
I could not reproduce this issue after several attempts on the Flame and Aries devices.

The contact always saved properly whether I created a new one or added to an existing one from a number that I dialed in dialer. 

Device: Flame 2.5 (Full Flash)(KK)(319mb)
BuildID: 20150713010204 
Gaia: e4b63559eba364892867eb381c3002d6518e5d6a
Gecko: eab21ec484bb
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Environmental Variables:
Device: Aries 2.5
BuildID: 20150619225606
Gaia: 4c06ed88ddccaba8dc941e5006bd2a9e57306f07
Gecko: 7c1a6b1151a1539186b950a144387e2d7f378d1b
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 41.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted
Correction to the Aries environmental variables:

Device: Aries 2.5
BuildID: 20150713103207
Gaia: a7439b6ca88264734171ff5ea0b6a0b8df3f258e
Gecko: 38d03bf4616e
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Assignee: nobody → francisco
Status: NEW → ASSIGNED
Checked this and could not reproduce.

Closing as works for me, if you see it happening again, please reopen.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
Created attachment 8639822 [details] [diff] [review]
adb.patch

I've reproduced this bug too, but it looks as a race condition related with first run, because if the phone is flashed, you execute the STR and the error happens, then the error will happen every time, but if after first run and executing STR you can't reproduce it, it won't happen at any time.

The problem that you can find is that to catch the traces you need to have adb active at boot time, and by default that's not the case (and even less on production builds). I've attached a small patch that you can use to enable this.
You need to log in before you can comment on or make changes to this bug.