Closed Bug 1177134 Opened 9 years ago Closed 9 years ago

ESLint cleanup, batch #1

Categories

(DevTools :: Console, defect)

40 Branch
defect
Not set
normal

Tracking

(firefox41 fixed)

RESOLVED FIXED
Firefox 41
Tracking Status
firefox41 --- fixed

People

(Reporter: jfong, Assigned: jfong)

References

Details

Attachments

(1 file)

      No description provided.
Attached patch Bug1177134.patchSplinter Review
First batch of tests. Let me know if anything should be adjusted.

Try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=02acc9eacec5
Attachment #8626091 - Flags: review?(pbrosset)
Comment on attachment 8626091 [details] [diff] [review]
Bug1177134.patch

Review of attachment 8626091 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for working on this Jen.
The changes look good to me. I haven't spent too much time looking at the details but they look mechanical enough, and try is green.
r=me

::: browser/devtools/webconsole/test/browser_bug_638949_copy_link_location.js
@@ +80,5 @@
>    info("expected clipboard value: " + message.url);
>  
>    let deferred = promise.defer();
>  
> +  waitForClipboard((aData) => {

2 minor remarks:
- while we're at it, let's rename aData to data (https://wiki.mozilla.org/DevTools/CodingStandards#Code_style)
- parenthesis can be removed around aData since it's only 1 argument.

::: browser/devtools/webconsole/test/browser_cached_messages.js
@@ +18,5 @@
>  
>    loadTab(TEST_URI).then(testOpenUI);
>  }
>  
> +function testOpenUI(aTestReopen) {

Same remark about aArgument here.

::: browser/devtools/webconsole/test/browser_console_error_source_click.js
@@ +17,5 @@
>    loadTab(TEST_URI).then(() => {
>      HUDService.toggleBrowserConsole().then(browserConsoleOpened);
>    });
>  
> +  function browserConsoleOpened(aHud) {

Since you're changing this line, it's a good opportunity to rename aHud to hud.
We probably shouldn't use this bug to get rid of *all* aArgument notations, but I guess if you're already changing lines that have some declarations in them, it's a good chance to do this for them.
Attachment #8626091 - Flags: review?(pbrosset) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/b026f257192e
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: