Closed Bug 1177136 Opened 5 years ago Closed 4 years ago

The loading throbber is blurry on HiDPI Windows

Categories

(Firefox :: Theme, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 42
Tracking Status
firefox40 --- verified
firefox41 --- verified
firefox42 --- verified

People

(Reporter: jaws, Assigned: bwinton)

References

Details

Attachments

(1 file, 1 obsolete file)

No description provided.
Flags: needinfo?(shorlander)
Assignee: jaws → nobody
Status: ASSIGNED → NEW
Attached patch The first cut at the patch. (obsolete) — Splinter Review
Stephen suggested we use the OSX throbbers as a stop-gap until we get better images, so that's what this patch does.
Assignee: nobody → bwinton
Status: NEW → ASSIGNED
Flags: needinfo?(shorlander)
Attachment #8639449 - Flags: ui-review?(shorlander)
Attachment #8639449 - Flags: review?(jaws)
Comment on attachment 8639449 [details] [diff] [review]
The first cut at the patch.

Review of attachment 8639449 [details] [diff] [review]:
-----------------------------------------------------------------

This changes the loading throbber from green to blue. As long as Stephen is OK with that them this is fine. The connecting throbber doesn't have as noticeable of a change besides more detail.
Attachment #8639449 - Flags: review?(jaws) → review+
Ooh, good catch!  This is the same as the previous version, but with the regular (@1x) loading image replaced, too, so that the colour remains consistent (and blue) between resolutions…
Attachment #8639449 - Attachment is obsolete: true
Attachment #8639449 - Flags: ui-review?(shorlander)
Attachment #8639462 - Flags: ui-review?(shorlander)
Attachment #8639462 - Flags: review+
Comment on attachment 8639462 [details] [diff] [review]
The next version of the patch.

Review of attachment 8639462 [details] [diff] [review]:
-----------------------------------------------------------------

Changing it to blue WFM.
Attachment #8639462 - Flags: ui-review?(shorlander) → ui-review+
Keywords: checkin-needed
Comment on attachment 8639462 [details] [diff] [review]
The next version of the patch.

Approval Request Comment
[Feature/regressing bug #]: Windows 10
[User impact if declined]: Uglier tab loading throbber on Windows.
[Describe test coverage new/current, TreeHerder]: Manual testing on Windows 8 and 10.
[Risks and why]: Low risk, css and image change.
[String/UUID change made/needed]: None
Attachment #8639462 - Flags: approval-mozilla-beta?
Attachment #8639462 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/5d5441040c8c
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
See Also: → 605890
¡Hola Blake!

You've inadvertently or unintentionally fixed https://bugzilla.mozilla.org/show_bug.cgi?id=605890 and for that I'm thankful =D

This works on Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0 ID:20150729030208 CSet: 2ee9895e032c

¡Hola Jared!

Perhaps this should be done across all platforms and fix https://bugzilla.mozilla.org/show_bug.cgi?id=605245 as well?

¡Gracias!
Status: RESOLVED → VERIFIED
Flags: needinfo?(jaws)
Comment on attachment 8639462 [details] [diff] [review]
The next version of the patch.

Low risk, verified fix in support of Windows 10. Beta+ Aurora+
Attachment #8639462 - Flags: approval-mozilla-beta?
Attachment #8639462 - Flags: approval-mozilla-beta+
Attachment #8639462 - Flags: approval-mozilla-aurora?
Attachment #8639462 - Flags: approval-mozilla-aurora+
Blocks: 605890
See Also: 605890
Flags: qe-verify+
(In reply to alex_mayorga from comment #8)
> Perhaps this should be done across all platforms and fix
> https://bugzilla.mozilla.org/show_bug.cgi?id=605245 as well?

Yes, we should do it across the board.
Flags: needinfo?(jaws)
Confirming this fix on a Microsoft Surface Pro 2 device running Windows 10 64-bit using:
* latest 42.0a1 Nightly,
* latest 41.0a2 Aurora and
* Firefox 40.0RC build 4.
Depends on: 1327400
You need to log in before you can comment on or make changes to this bug.