Closed Bug 1177280 Opened 5 years ago Closed 4 years ago

Automatically recognise device in addon

Categories

(Firefox OS Graveyard :: B2gInstaller, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
FxOS-S2 (10Jul)

People

(Reporter: daleharvey, Assigned: daleharvey)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files, 2 obsolete files)

No description provided.
So we need a device.json somewhere accessible on the web as well as up to date blob free builds hosted somewhere. I think we could put a devices.json on github and we can have up to date builds from task cluster hosted somewhere?

Wander can we add some builds (flame, shimani + aries) that have their blobs removed built and hosted by taskcluster? Alexandre could you give Wander a little bit of context about how to generate these builds?
Flags: needinfo?(wcosta)
Flags: needinfo?(lissyx+mozillians)
We already have this ongoing, I'm not able to find the bug but Wander has filed it.
Flags: needinfo?(lissyx+mozillians)
Awesome sorry still catching up, wander if you could link that bug it would be super useful. for the devices.json file, make https://github.com/mozilla-b2g/b2g-installer-devices/ that has a devices.json file in it we can make pr's to and fetch from the addon from github?
Bug 1175934
Flags: needinfo?(wcosta)
Assignee: nobody → dale
Just an update on my WIP
(In reply to Dale Harvey (:daleharvey) from comment #5)
> Created attachment 8626413 [details]
> Screen Shot 2015-06-25 at 18.19.28.png
> 
> Just an update on my WIP

\o/
Comment on attachment 8626413 [details]
Screen Shot 2015-06-25 at 18.19.28.png

land!!!§§§
Attachment #8626413 - Flags: review+
Depends on: 1179771
Target Milestone: --- → FxOS-S2 (10Jul)
Whiteboard: [systemsfe]
Ok, again very sorry for the huge wait on this.

The UX isnt final, needs some cleaning up but mainly waiting on the graphics, I did most of specified UX and will plug the UX in + clean up the last of it when I get the graphics.

This is not working for me, I am still trying to debug the fastboot crash in osx, it seems entirely inside adb-helper so if this works for you then I think its ok to land.

One thing I still want to clean up is that I dont verify the validity of user uploaded builds any more, but with the way the isSupportedConfig has been refactored out a little, should be easy to readd back in. I will do that before asking for a proper review.

Obviously need to fix these to use proper build urls, although I think that should be a seperate follow up.
Attachment #8639189 - Flags: feedback?(lissyx+mozillians)
Also needinfoing James

Hey, apologies for being the blocker on your improvements, however the new UX ended up being a fairly large shift, if you want to test this out would also be super useful, cheers

Ill be working on getting this landable based on what I head back from Alexandre, then hopefully it will be a bit easier to all work on it together
Flags: needinfo?(hobinjk)
Comment on attachment 8639189 [details] [review]
https://github.com/lissyx/b2g-installer/pull/5

I have not tested it yet, there are a few things that looks spurious/unclear to me.
Flags: needinfo?(dale)
Comment on attachment 8639189 [details] [review]
https://github.com/lissyx/b2g-installer/pull/5

After a local testing, that looks good but still need some work :)
Attachment #8639189 - Flags: feedback?(lissyx+mozillians) → feedback+
(In reply to Dale Harvey (:daleharvey) from comment #9)
> Also needinfoing James
> 
> Hey, apologies for being the blocker on your improvements, however the new
> UX ended up being a fairly large shift, if you want to test this out would
> also be super useful, cheers
> 
> Ill be working on getting this landable based on what I head back from
> Alexandre, then hopefully it will be a bit easier to all work on it together

No problem! I can't wait to see when this comes together. Looking over the PR, it seems like most of my changes can be applied on top of this easily (with the changes to support l10n and so on).
Flags: needinfo?(hobinjk)
Attached file VsD_FlashingTool_Spec_1.0.pdf (obsolete) —
VSD spec for flashing tool
Attached file Sliced Graphics.zip (obsolete) —
Graphics for flashing tool. Let me know if you have any questions or need anything else from me. 

Cheers, 
Amy
Comment on attachment 8641892 [details]
VsD_FlashingTool_Spec_1.0.pdf

I posted VSD spec in the meta bug instead (Bug 1166276)
Attachment #8641892 - Attachment is obsolete: true
Comment on attachment 8641893 [details]
Sliced Graphics.zip

Posting this in the meta bug instead (Bug 1166276)
Attachment #8641893 - Attachment is obsolete: true
Comment on attachment 8639189 [details] [review]
https://github.com/lissyx/b2g-installer/pull/5

Updated the pull request

You were right about a race in Devices.on('register'), now we register a single time and have an event for the UI to listen to.

Fixed a few other bugs found (you mentioned some on irc), I still cant test fastboot / the full flash mode, but debugging now and I think its a good idea to get this landed and get people unblocked while we debug the crash
Flags: needinfo?(dale)
Attachment #8639189 - Flags: review?(lissyx+mozillians)
Sorry for the delay, I have lost more time than expected on hacking Xperia M2. I'll give your code a review soon, but in the meantime we should make sure that UX is good on one point I thought about this morning: when flashing from Android we should make it clear that we *NEED* to format userdata partition. So the "Keep my data" should be only displayed for B2G, and we should warn user before erasing its data.

Given the partition layout, it will erase also the Internal SD.
Flags: needinfo?(dale)
Comment on attachment 8639189 [details] [review]
https://github.com/lissyx/b2g-installer/pull/5

So that's good. There are some UX improvements we should definitively make but they should not block this landing.

I just have one big issue with this is that when you first extract the ZIP file, the permissions may fail to get set (that always happened to me, the error is "Failed to set permissions 644 on /tmp/b2g-installer/aries/content/SYSTEM/lib/libGLESv3.so [Exception... "Component returned failure code: 0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST) [nsIFile.permissions]"  nsresult: "0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST)"  location: "JS frame :: resource://gre/modules/ZipUtils.jsm :: ZipUtils_extractFiles :: line 211"  data: no]" in the Firefox stdout).

With the current code, this is blocking the process (with poor feedback, but that's fixable) while it is not a prolem because we don't care really about permissions. That's the only thing I want to see fixed before landing. Except this, all works quite well.
Attachment #8639189 - Flags: review?(lissyx+mozillians) → review+
Hopefully the permissions issue shouldnt block progress now, but I cant really fix that without reproducing it and it doesnt reproduce on osx / ubuntu for me.

I have landed and working on the follow ups now, cheers

https://github.com/mozilla-b2g/b2g-installer/commit/eb96c596941ff3c77ea3d179c00d365c935ab3e8
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(dale)
Resolution: --- → FIXED
> Hopefully the permissions issue shouldnt block progress now, 
> but I cant really fix that without reproducing it and it doesnt reproduce on osx / ubuntu for me.

Just to clarify, I changed it so an error during extraction isnt fatal, we jut ignore it.
Component: General → B2gInstaller
You need to log in before you can comment on or make changes to this bug.