Aries - Bugzilla Lite doesn't lock the submitting button when sending the bug

VERIFIED FIXED in Firefox OS master

Status

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: snowmantw, Assigned: daleharvey)

Tracking

unspecified
FxOS-S4 (07Aug)

Firefox Tracking Flags

(feature-b2g:2.5+, b2g-master verified)

Details

(Whiteboard: [bzlite])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

1. Fire a bug
2. Open the Filed one in Bugzilla Lite
3. Send some reply

Expect: the send button would be locked (disabled), so it won't send it twice

Actual: the button is not disabled, and there is no UI shows it's sending, so the reply could be sent multiple times. In fact, I made this mistake about 5 mins ago.
(Reporter)

Comment 1

3 years ago
And sorry the title may be not accurate: only reply then saving change would be sent multiple times.
Dale, something to consider fixing.
Flags: needinfo?(pdolanjski)
Flags: needinfo?(dale)
(Assignee)

Comment 3

3 years ago
Yup its on the list
Flags: needinfo?(dale)
[Blocking Requested - why for this release]:
Status: UNCONFIRMED → NEW
QA Whiteboard: [foxfood-triage]
Component: Gaia::Feedback → Gaia::Bugzilla Lite
Ever confirmed: true
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1180066
(Assignee)

Updated

3 years ago
Blocks: 1180660
feature-b2g: --- → 2.5+
(Assignee)

Updated

3 years ago
Assignee: nobody → dale
Attachment #8640420 - Flags: review?(drs) → review+
(Assignee)

Comment 7

3 years ago
Cheers, amended commit with comments and landed

https://github.com/mozilla-b2g/bzlite/commit/44b4344a4cd2c895617353779468e0b140a5ef0c
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(pdolanjski)
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S4 (07Aug)
This issue is verified fixed on Aries. On bugzilla lite app, a reply can only be sent once - the 'save changes' button is disabled after it has been tapped once.

Device: Aries 2.5
BuildID: 20150831032308
Gaia: 31e595f86f6bf159b3a9a46816a6ac00a55ca9f9
Gecko: f2518b8a7b97b5bb477e94bc9131584007aac887
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [foxfood-triage] → [foxfood-triage], [QAnalyst-Triage?]
status-b2g-master: --- → verified
Flags: needinfo?(jmercado)
Keywords: verifyme
QA Whiteboard: [foxfood-triage], [QAnalyst-Triage?] → [foxfood-triage], [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.