Closed Bug 1177349 Opened 6 years ago Closed 6 years ago

[Music]Music won't be played automaticly if we play a song the second time which is an attachment of email.

Categories

(Firefox OS Graveyard :: Gaia::Music, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(tracking-b2g:backlog, b2g-v2.2 affected, b2g-master verified)

VERIFIED FIXED
tracking-b2g backlog
Tracking Status
b2g-v2.2 --- affected
b2g-master --- verified

People

(Reporter: huayu.li, Assigned: justindarc)

Details

(Whiteboard: [v2.2-nexus-5-l])

Attachments

(4 files)

Attached file logcat1.txt
[1.Description]:
[Nexus5 2.2][Flame2.2&3.0]Music app runs in background and a song is being played. If we play a song which is an attachment of email, then back to email and play this song again, the song won't be played automatically, and the elapsed time is wrong.
Found at:3:54
see attachments:logcat1.txt, 1.3gp

[2.Testing Steps]: 
Precondition:There is an email which contains a song attachment.
1.Launch music and play a song.
2.Tap home button.
3.Launch email.
4.Open the email in precondition.
5.Download the song which is an email attachment.
6.Tap preview icon to play this song.
7.After playing some seconds, tap back button to email view.
8.Tap preview icon to play the song again.

[3.Expected Result]: 
8.The song should be played automaticly and the playing time should start from 00:00.

[4.Actual Result]: 
8.We can see the song won't be played, the playing time is same with step 7, if we tap play icon twice, the song will be played from beginning, but while the time go to the end, the song not be played complete, and it stopped.

[5.Reproduction build]: 
Device: Flame3.0[Affected]
Build ID               20150624080416
Gaia Revision          eb0d4aefa62b20420d6fa0642515a110daca5d97
Gaia Date              2015-06-24 01:48:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4cdc1a95a672
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150624.153831
Firmware Date          Wed Jun 24 15:38:44 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2[Affected]
Build ID               20150624162504
Gaia Revision          1f8981d7872e3c0053571c26fb3edaf401844d75
Gaia Date              2015-06-19 13:22:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2f8b845e5fa3
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150624.195750
Firmware Date          Wed Jun 24 19:58:02 EDT 2015
Bootloader             L1TC000118D0

Device:Nexus5 3.0[Unaffected]
Build ID               20150624010204
Gaia Revision          311c4e59936a407e64509f54fecb440d8a78e3c8
Gaia Date              2015-06-20 20:21:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/be81b8d6fae9
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150624.043116
Firmware Date          Wed Jun 24 04:31:35 EDT 2015
Bootloader             HHZ12f

Device:Nexus5 2.2[Affected]
Build ID               20150624002503
Gaia Revision          1f8981d7872e3c0053571c26fb3edaf401844d75
Gaia Date              2015-06-19 13:22:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3268ab642b70
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150624.034819
Firmware Date          Wed Jun 24 03:48:36 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached video 1.3gp
No-Jun, could you take a look?
Flags: needinfo?(npark)
While I don't think it's a blocking issue (since it's not a regression either), i'm needinfoing hub to double check.
Flags: needinfo?(npark) → needinfo?(hub)
[Tracking Requested - why for this release]:
It does not reproduce on nexus 5l: making me suspect that this might be related to memory constraint. Tracking flag set since it's awaiting on ni? flag (Once the ni? is answered, we can decide to nom it for 2.5 or keep it in the backlog bin.
Flags: needinfo?(hub)
I feel like I fixed a similar issue recently, but I'm having a hard time finding it. Could QA take a look to see if this still happens?
Keywords: qawanted
Bug Repro's per these builds: 
Environmental Variables:
Device: Flame 2.5
Build ID: 20151002030232
Gaia: 9a682cb7bc8b7fde624a9b2b3c2d64415a08b04b
Gecko: 5f16c6c2b969f70e8da10ee34853246d593af412
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

RESULTS: 
When playing a song via the Music App, then playing an .mp3 file via an email attachment, 
the attached file doesn't play on the second try as expected. Reproed (4/5) tries.


REPRO on this BUILD: 
Environmental Variables:
Device: Aries 2.5
BuildID: 20151002110438
Gaia: 9a682cb7bc8b7fde624a9b2b3c2d64415a08b04b
Gecko: 5f16c6c2b969f70e8da10ee34853246d593af412
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

RESULTS: 
When playing a song via the Music App, then playing an .mp3 file via an email attachment, 
the attached file doesn't play on the second try as expected. Reproed (3/5) tries.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
QA Contact: sleedavid
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Keywords: qawanted
I think this is actually an AudioChannel issue.
(In reply to Jim Porter (:squib) from comment #7)
> I think this is actually an AudioChannel issue.

Not AudioChannel. I know what's going on here. Patch on the way.
Assignee: nobody → jdarcangelo
Status: NEW → ASSIGNED
Comment on attachment 8671029 [details] [review]
[gaia] justindarc:bug1177349 > mozilla-b2g:master

Had a real hard time reproducing this problem, but it did happen. A JS error was being thrown from not having the <music-scan-progress> web component loaded during startup. I'm guessing this was causing a race condition where the song would not load if the error was thrown before we tried queueing up the song.
Attachment #8671029 - Flags: review?(squibblyflabbetydoo)
Comment on attachment 8671029 [details] [review]
[gaia] justindarc:bug1177349 > mozilla-b2g:master

Looks good to me!
Attachment #8671029 - Flags: review?(squibblyflabbetydoo) → review+
Landed on master:

https://github.com/mozilla-b2g/gaia/commit/eb28e05f4713fab5c1f050a9198fc4d5144bb521
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
According to the STR of Comment 0, this bug has been verified as pass on latest Flame KK v2.2 & v2.5 and Aries KK v2.5.

Actual results: The song is played automaticly and the playing time starts from 00:00.
See attachment: verified_Aries KK v2.5.3gp
Reproduce rate: 0/6

Device: Flame KK v2.2 (Pass)
Build ID               20151012032501
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ab6c34bfacf7
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151012.072013
Firmware Date          Mon Oct 12 07:20:24 EDT 2015
Fireware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.5 (Pass)
Build ID               20151012150203
Gaia Revision          0b934d06c04adff2cd9bdd0bc204f974a18b710f
Gaia Date              2015-10-12 12:15:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f4215b484d529e01f0f84ff4005e3321ee98b727
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151012.183433
Firmware Date          Mon Oct 12 18:34:45 EDT 2015
Fireware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5 (Pass)
Build ID               20151012230518
Gaia Revision          0b934d06c04adff2cd9bdd0bc204f974a18b710f
Gaia Date              2015-10-12 12:15:30
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/11ff0ccb7d59311df4c190d331c8b58c6e35a0c8
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151012.224830
Firmware Date          Mon Oct 12 22:48:38 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+], [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.