[Built-in&System Keyboard]While we intend to input a wifi password, if we press the home button, the keyboard will not disappear.

VERIFIED FIXED

Status

Firefox OS
Gaia::Keyboard
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: zouyi(Leave from Mozilla), Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master unaffected)

Details

(Whiteboard: [v2.2-nexus-5-l])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8626071 [details]
logcat001.txt

[1.Description]:
[Nexus5 v2.2][Flame 2.2]While we intend to input a wifi password, if we press the home button, the keyboard will not disappear.
Time:16:55
See attachment: logcat001.txt,VIDEO0589.3gp
[2.Testing Steps]: 
1.Make sure wifi is not connected.
2.Tap rocket bar at home screen.
3.Tap one or several characters.
4.Tap the No internet connection button.
5.Tap Wi-Fi.
6.Chose a wifi which has a password.
7.Tap the password field.
8.Tap the home button.

[3.Expected Result]: 
8.We can return to home screen without issue.

[4.Actual Result]: 
8.We return to home screen but the keyboard does not disappear.

[5.Reproduction build]: 
Device: Flame 2.2 [affected]
Build ID               20150624162504
Gaia Revision          1f8981d7872e3c0053571c26fb3edaf401844d75
Gaia Date              2015-06-19 13:22:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2f8b845e5fa3
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150624.195750
Firmware Date          Wed Jun 24 19:58:02 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 [unaffected]
Build ID               20150624080416
Gaia Revision          eb0d4aefa62b20420d6fa0642515a110daca5d97
Gaia Date              2015-06-24 01:48:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4cdc1a95a672
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150624.153831
Firmware Date          Wed Jun 24 15:38:44 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus5 2.2 [affected]
Build ID               20150624002503
Gaia Revision          1f8981d7872e3c0053571c26fb3edaf401844d75
Gaia Date              2015-06-19 13:22:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3268ab642b70
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150624.034819
Firmware Date          Wed Jun 24 03:48:36 EDT 2015
Bootloader             HHZ12f

Device: Nexus5 3.0 [unaffected]
Build ID               20150624010204
Gaia Revision          311c4e59936a407e64509f54fecb440d8a78e3c8
Gaia Date              2015-06-20 20:21:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/be81b8d6fae9
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150624.043116
Firmware Date          Wed Jun 24 04:31:35 EDT 2015
Bootloader             HHZ12f


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8626073 [details]
VIDEO0589.3gp
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → unaffected
It is a regression. Please help find regression window.
Keywords: qawanted, regression, regressionwindow-wanted
Confirmed that it's a regression because v2.1 is unaffected. I'll be working on getting the reverse window first, and if that doesn't work out then I'll get the actual regression window.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Contact: pcheng
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
b2g-inbound reverse regression window (fixed window):

Last Broken
Device: Flame
BuildID: 20150611084742
Gaia: e158dea4ff49514cacc42c3d7a9ac281779e41d7
Gecko: 128f2eb5c224
Version: 41.0a1 (2.5 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Working
Device: Flame
BuildID: 20150611090741
Gaia: 5df334619e9d11ca4c55bf930e198b5829d026f7
Gecko: 58491854d71c
Version: 41.0a1 (2.5 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Last Broken Gaia & First Working Gecko - repro
Gaia: e158dea4ff49514cacc42c3d7a9ac281779e41d7
Gecko: 58491854d71c

Last Broken Gecko & First Working Gaia - no repro
Gaia: 5df334619e9d11ca4c55bf930e198b5829d026f7
Gecko: 128f2eb5c224

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/e158dea4ff49514cacc42c3d7a9ac281779e41d7...5df334619e9d11ca4c55bf930e198b5829d026f7

This issue was fixed on 2.5 Master by changes made in Bug 1163524.
QA Whiteboard: [QAnalyst-Triage?]
Depends on: 1163524
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Alberto, this was fixed on 2.5 by the landing for bug 1163524. Can we get that same fix uplifted to 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(apastor)
Just asked for approval on bug 1163524. Thanks!
Flags: needinfo?(apastor)
Created attachment 8630408 [details]
verified_v2.2.3gp

This bug has been verified as pass on latest build of Flame V2.2 & Nexus5 V2.2 by the STR in Comment 0.

Actual results:We return to home screen without issue.

See attachment:verified_v2.2.3gp

Reproduce rate: 0/5

Device: Flame 2.2 build(Pass)
Build ID               20150706162504
Gaia Revision          ea11f422b687a982f0a961c9aea7858066561707
Gaia Date              2015-07-02 23:37:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/52d19a805d35
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150706.200602
Firmware Date          Mon Jul  6 20:06:13 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus5 2.2 build(Pass)
Build ID               20150623223009
Gaia Revision          eb0d4aefa62b20420d6fa0642515a110daca5d97
Gaia Date              2015-06-24 01:48:14
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/4ab2192fc513
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150706.200102
Firmware Date          Mon Jul  6 20:01:20 EDT 2015
Bootloader             HHZ12f
status-b2g-v2.2: affected → verified
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.