bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Element heights being calculated incorrectly since upgrade to 38.05

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Geat, Unassigned)

Tracking

({testcase})

38 Branch
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8626162 [details]
Firefox-Height-Bug.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.130 Safari/537.36

Steps to reproduce:

Placed two child DIVs (with top and bottom margins and padding, but no borders) inside a parent DIV. Calculated the heights of the child DIVs (either manually using the object inspector, or using JavaScript, the result is the same).


Actual results:

The height of the parent was reported at 1 pixel smaller than it should have been (see attached screenshots): 423+586 = 1009, the browser calculates the height as 1008.


Expected results:

The height of the parent should be equal to the heights of the two child elements.

This was working before the latest Firefox upgrade, and works in all other major browsers (even Safari!)

Comment 1

3 years ago
Could you attach  a simple testcase to the bug, please.
Flags: needinfo?(geat)
Keywords: testcase-wanted
Hi Geat, 

Are you still encountering this issue in the newest version of Firefox (42)?
Created attachment 8720214 [details]
testcase.html

User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID 	20160216030245

User Agent 	Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID 	20150508094354

Tested on Windows 7 x64 with the Nightly 47.0a1 build and the Release 38.0 build. I can't reproduce the problem with the tescase I created based on the image provided.
Reporter, does this issue reproduce on the latest version of Firefox (https://www.mozilla.org/en-US/firefox/new/)? If yes, can you provide more details?
Thank you.

Comment 4

2 years ago
WFM in 38.0.5 with comment 3.

Feel free to reopen the bug if the issue still reproducible in latest release.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(geat)
Keywords: testcase-wanted → testcase
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.