[Settings] Introduce gaia-checkbox in developer panel

RESOLVED FIXED in FxOS-S1 (26Jun)

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: kgrandon, Assigned: kgrandon)

Tracking

unspecified
FxOS-S1 (26Jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
In preparation of moving away from building blocks, and onto web components. Also fixes a few issues with the gaia-checkbox component that will make it easier to use everywhere.
(Assignee)

Comment 1

3 years ago
Created attachment 8626192 [details] [review]
[Pull Request] Convert developer panel checkboxes to use gaia-checkbox
(Assignee)

Comment 2

3 years ago
Comment on attachment 8626192 [details] [review]
[Pull Request] Convert developer panel checkboxes to use gaia-checkbox

Hi Arthur - next up I would like to start porting checkboxes to use gaia-checkbox. Could you give this a review if you have a chance? Thanks!
Attachment #8626192 - Flags: review?(arthur.chen)
Comment on attachment 8626192 [details] [review]
[Pull Request] Convert developer panel checkboxes to use gaia-checkbox

Thanks for taking the effort, Kevin. Overall the patch is looking good, but the text color should be overrided to black.

And I noticed that the highlight was gone after using gaia components, just want to make sure this is by design. I'm fine with that if we are going to improve it from the component side.
Attachment #8626192 - Flags: review?(arthur.chen)
(Assignee)

Comment 4

3 years ago
Comment on attachment 8626192 [details] [review]
[Pull Request] Convert developer panel checkboxes to use gaia-checkbox

Hi Arthur, thank you very much for the review. I've addressed your nit and added another commit with the color fix which I will squash. Regarding the :active highlight, we are currently doing this initial work and will swap out the components with the new versions which have a different hover state. (We would like to land this initial work for that, but our next release will definitely have an :active state)

Please take another look when you get a chance. Thanks!
Attachment #8626192 - Flags: review?(arthur.chen)
Comment on attachment 8626192 [details] [review]
[Pull Request] Convert developer panel checkboxes to use gaia-checkbox

r=me, thanks!
Attachment #8626192 - Flags: review?(arthur.chen) → review+
(Assignee)

Comment 6

3 years ago
In master: https://github.com/mozilla-b2g/gaia/commit/5997b406e77ea726fbd9047057a1c3504f6cd6d4
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Blocks: 1178543
Target Milestone: --- → FxOS-S1 (26Jun)
You need to log in before you can comment on or make changes to this bug.