Closed Bug 1177509 Opened 4 years ago Closed 4 years ago

[Aries] SHB is too easy to accidentally trigger when hitting space button on the Keyboard

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED
FxOS-S2 (10Jul)

People

(Reporter: mikehenrty, Assigned: rakhavan)

References

Details

(Whiteboard: [spark][systemsfe])

Attachments

(2 files, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #1171235 +++

I'm "re-opening" this bug since we continue to have feedback that hitting the SHB is too easy. Perhaps we can add some deadspace to the bottom of the keyboard. Or move the actual circle icon down.
Assignee: nobody → rakhavan
Attachment #8626458 - Flags: review?(mhenretty)
I'm going to put this on my foxfooding device and try it out for a day or so. Thanks!
Comment on attachment 8626458 [details] [review]
PR: Increase the size of the shb dead space

Ahhh, the dead space bar is not working. It's inheriting `pointer-events: none` from [1]. Not sure if we need to increase the dead space from the last one or not because AFAICT it never worked as intended.

1.) https://github.com/mozilla-b2g/gaia/blob/0b166043ef2a1f235a4d7d4f40a51b625784195a/apps/system/style/software_button_manager/software_button_manager.css#L35
Attachment #8626458 - Flags: review?(mhenretty)
Good find! Even after making it taller I experienced this symptom for the last couple days and thought my thumbs were just over-sized. After putting this fix on my z3c it's noticeably better now. If you'd like me to reduce the height of the dead space let me know.
Attachment #8626458 - Attachment is obsolete: true
Attachment #8627062 - Flags: review?(mhenretty)
Comment on attachment 8627062 [details] [review]
PR: updated with pointer events

After using this, I can safely say this helps a lot. Good job!
Attachment #8627062 - Flags: review?(mhenretty) → review+
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/fe01a479af3ff57ea5e0b07dad1cb1143edda4ca
Status: NEW → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S2 (10Jul)
Duplicate of this bug: 1180451
You need to log in before you can comment on or make changes to this bug.