Having to enable an addon after installing it via WebIDE is VERY annoying

RESOLVED DUPLICATE of bug 1220700

Status

()

Firefox
Developer Tools: WebIDE
RESOLVED DUPLICATE of bug 1220700
3 years ago
2 years ago

People

(Reporter: sole, Assigned: ochameau)

Tracking

({DevAdvocacy, foxfood})

Firefox Tracking Flags

(Not tracked)

Details

Each time I push the addon I have to make my way to the Settings app, Addons tab, the particular addon I installed, and enable it.

This workflow is horrible :-(

Updated

3 years ago
Component: Gaia::Foxfooding → Gaia::Customizer
Keywords: dogfood
QA Whiteboard: [top-dogfood]
Hm, strange. I thought I fixed that in bug 1162791
FWIW, it gets auto-enabled when you install it from Hackerplace, so maybe webIDE does something different than just mozApps.install.
Component: Gaia::Customizer → Developer Tools: WebIDE
Product: Firefox OS → Firefox
ochameau, any ideas?
Flags: needinfo?(poirot.alex)
QA Whiteboard: [top-dogfood] → [top-dogfood],[foxfood-triage]

Updated

2 years ago
Keywords: dogfood → foxfood
Alexandre I assigned you to take a look at this, feel free to redirect.
Assignee: nobody → poirot.alex
(Assignee)

Comment 5

2 years ago
This bug is very old and was reported from old and deprecated addons mechanism.
Is it still buggy?
Note that bug 1220700 recently fixed a regression around addon enabling.
Flags: needinfo?(poirot.alex) → needinfo?(mhenretty)
I'll re-test this once bug 1220700 makes it into nightly.
I didn't enable the addon by default in bug 1220700, but it's a one liner and I can fold this change in bug 1220700.
Thanks Fabrice. I just confirmed that with the latest build and webIDE, add-ons are automatically enabled when installed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(mhenretty)
Resolution: --- → DUPLICATE
Duplicate of bug: 1220700
You need to log in before you can comment on or make changes to this bug.