Closed Bug 1177558 Opened 6 years ago Closed 5 years ago

Allocations tree (and chart) is always empty

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect)

defect
Not set
normal

Tracking

(firefox42 fixed)

RESOLVED FIXED
Firefox 42
Tracking Status
firefox42 --- fixed

People

(Reporter: fitzgen, Assigned: jsantell)

References

Details

Attachments

(1 file)

Make sure you have "record allocations" checked. Restart firefox after checking.

STR:

* Open perf tool
* Go to https://swannodette.github.io/todomvc/labs/architecture-examples/om/
* Start recording
* Click "benchmark 1"
* Stop recording
* Go to allocations tree

ER:

Allocations appear ("benchmark 1" definitely allocates)

AR:

Nothing there. Nor in allocation charts.
Assignee: nobody → jsantell
Status: NEW → ASSIGNED
This is from trying to offset the docshell timestamps by a Date.now() in the memory actor, leaving us with wildly negative numbers. Saving this for when the performance actor is a real actor, to make things way easier.
Depends on: 1172180
Duplicate of this bug: 1175772
Moved logic that fixed this from bug 1172180 to here. The docshell timing is weird how we do it, but that's how we do it everywhere else, and if it's ugly, it's because we should clean it up everywhere
Attachment #8643382 - Flags: review?(nfitzgerald)
Comment on attachment 8643382 [details] [diff] [review]
1177558-fix-allocs.patch

Review of attachment 8643382 [details] [diff] [review]:
-----------------------------------------------------------------

Played with it and everything works again! Great!
Attachment #8643382 - Flags: review?(nfitzgerald) → review+
https://hg.mozilla.org/mozilla-central/rev/7c556da6de98
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.