Implement unprivileged execCommand("copy") and execCommand("cut")

VERIFIED FIXED

Status

()

Firefox
Untriaged
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: Alan Tam, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 1012662])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8626368 [details]
clipboard-execCommand.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.130 Safari/537.36

Steps to reproduce:

Chrome 43 decides that allowing the website to pollute your clipboard inside _any_ DOM event handler is no longer a concern. Can Firefox reconsider the policy to allow any website to do programmatically cut/copy text to clipboard?

http://codetheory.in/javascript-copy-to-clipboard-without-flash-using-cut-and-copy-commands-with-document-execcommand/

Test case attached.
I think Bug 1012662 has already fixed this. You can try your test on Nightly. It works! :)
I was able to reproduce the issue on Mac OS X 10.10.4 using Firefox 38.0 (20150429135941) and the str from Comment 0.

The issue is no longer reproducible on Mac OS X 10.10.4 and Windows 10 x86 using latest Nightly 44.0a1 (20151008030232) and below, so it seems that this has been indeed fixed by Bug 1012662.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 1012662]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.