EXIF orientation ignored - pictures taken from iPhone 6 display incorrectly in Firefox

RESOLVED WORKSFORME
(NeedInfo from)

Status

()

Core
Layout: Images
RESOLVED WORKSFORME
3 years ago
a year ago

People

(Reporter: jasonwuonline, Unassigned, NeedInfo)

Tracking

({reproducible, testcase})

38 Branch
reproducible, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-ie][parity-safari])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8626406 [details]
CF349412-1F39-4E01-BFB6-B9BD1D1A3B46_or.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.124 Safari/537.36

Steps to reproduce:

  Why firefox not supporting the orientation from picture taken IPhone 6.  The orientation on the EXIF meta data was set up 180 rotation.  


Actual results:

It works fine in IE and safari but not in firefox .   


Expected results:

it should display with 180 rotated orientation

Comment 1

3 years ago
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:41.0) Gecko/20100101 Firefox/41.0
20150626030206

The image is displayed correctly in IE 11, but not Chromium 43 or Opera 29.
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout: Images
Ever confirmed: true
Keywords: reproducible, testcase
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
Summary: Picture taken from IPhone 6 was orientated correctly in firefox → EXIF orientation ignored - pictures taken from iPhone 6 display incorrectly in Firefox
Whiteboard: [parity-ie][parity-safari]
Flags: needinfo?(seth)

Comment 2

a year ago
Not a bug.

This image itself (pixel-wise) has right orientation. However, it also has EXIF orientation: rotate 180. Therefore in any competent program (in other words, IE is not one), it will show as upside down.

I don't know how you end up get such an image (the original image from iPhone will NOT have this problem), but that's an irrelevant question.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.