ibm.com - WebSphere app server - Bad comments in strict mode causing problems

VERIFIED FIXED

Status

--
trivial
VERIFIED FIXED
17 years ago
4 years ago

People

(Reporter: crook, Assigned: bc)

Tracking

Details

(Whiteboard: [DOCTYPE], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.7) Gecko/20011221

I can't exactly tell what's wrong with this page and if this bug is already
opened - the page is too complicated for me.
But please take a look.

Reproducible: Always

Comment 1

17 years ago
The page has a DOCTYPE, which will trigger strict rendering, but is littered
with non-standard comment terminators, e.g. 
 <!---UPDATE HIGHLIGHTS SECTION--------->

See http://bugzilla.mozilla.org/show_bug.cgi?id=102127#c16
and
http://bugzilla.mozilla.org/show_bug.cgi?id=102127#c17

for details of why this will cause problems.

confirming ->Tech evangelism

Contact details from the page source :
<meta name="author" content="Andrew Golden">
<meta name="email" content="goldena@us.ibm.com">
Assignee: asa → doronr
Status: UNCONFIRMED → NEW
Component: Browser-General → US General
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: doronr → zach
Version: other → unspecified

Updated

17 years ago
Summary: Page looks awfully → ibm.com - Bad comments in strict mode causing problems
(Assignee)

Updated

17 years ago
Blocks: 114157
Keywords: evang500
(Assignee)

Comment 2

17 years ago
taking, issues related to DOCTYPE and layout have been communicated to IBM.
Assignee: doronr → bclary
Whiteboard: [DOCTYPE]

Comment 3

17 years ago
*** Bug 126996 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
bc: If your taking this bug, shouldn't you set Accept bug so it is no longer
marked as New?
(Assignee)

Comment 5

17 years ago
only when i contact them. they have been contacted about general issues
including doctypes and comments but i haven't followed up recently.
<!--UPDATE HIGHLIGHTS SECTION--> now - others like every IBM page

Updated

17 years ago
Severity: normal → trivial
Summary: ibm.com - Bad comments in strict mode causing problems → ibm.com - WebSphere app server - Bad comments in strict mode causing problems

Comment 7

17 years ago
Is this fixed? Looks same to me in Gecko and IE.

Comment 8

17 years ago
It seems that IBM has fixed this. The source no longer contains comments
containing "--".
(Assignee)

Updated

17 years ago
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

17 years ago
yep. fixed. thx.

Comment 10

16 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.