Closed Bug 1177670 Opened 6 years ago Closed 5 years ago

[RTL][Music]The "-" symbol is shown at right side of remaining time.

Categories

(Firefox OS Graveyard :: Gaia::Music, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:-, b2g-v2.2 affected, b2g-master affected)

RESOLVED WONTFIX
blocking-b2g -
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: yue.xia, Unassigned)

References

Details

(Whiteboard: [2.2-nexus-5-l][OGA only])

Attachments

(2 files)

Attached image Play music1.png
[1.Description]:
[RTL][Flame v2.2&v3.0][N5 v2.2&v3.0][Music]Device receives a mail that has a music attachment in it, then tap this mail and download the music attachment. After it is downloaded, tap the eye icon to play the music, the "-" symbol is shown at right side of remaining time.
See attachment: Play music1.png

[2.Testing Steps]: 
Prerequisite: Set system language as Arabic.
1. Log in an E-mail account.
2. Launch E-mail and tap a mail received that has a music attachment.
3. Tap download icon beside the music attachment..
4. Tap the eye icon to play the music.

[3.Expected Result]: 
4. On the music playing view, the "-" symbol should be shown at left side of remaining time.

[4.Actual Result]: 
4. On the now-playing view, the "-" symbol is shown at right side of remaining time.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150624162504
Gaia Revision          1f8981d7872e3c0053571c26fb3edaf401844d75
Gaia Date              2015-06-19 13:22:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2f8b845e5fa3
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150624.195750
Firmware Date          Wed Jun 24 19:58:02 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 version(Affected)
Build ID               20150624080416
Gaia Revision          eb0d4aefa62b20420d6fa0642515a110daca5d97
Gaia Date              2015-06-24 01:48:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4cdc1a95a672
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150624.153831
Firmware Date          Wed Jun 24 15:38:44 EDT 2015
Bootloader             L1TC000118D0

N5 2.2 version(Affected)
Build ID               20150625162500
Gaia Revision          1f8981d7872e3c0053571c26fb3edaf401844d75
Gaia Date              2015-06-19 13:22:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2f8b845e5fa3
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150625.212626
Firmware Date          Thu Jun 25 21:26:45 EDT 2015
Bootloader             HHZ12f

N5 3.0 version(Affected)
Build ID               20150625160206
Gaia Revision          038e917076271d304b906a41b4de670e505c67ae
Gaia Date              2015-06-25 00:22:19
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0b2f5e8b7be5
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150625.192222
Firmware Date          Thu Jun 25 19:22:41 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
QA Whiteboard: [rtl-impact]
[Blocking Requested - why for this release]:
Nominating as "-" and "+" symbols should show up at the left of numbers in RTL format (just like LTR). This doesn't make sense the way it is
blocking-b2g: --- → 2.5?
Priority: -- → P1
blocking-b2g: 2.5? → 2.5+
Assignee: nobody → jdarcangelo
Whiteboard: [2.2-nexus-5-l] → [2.2-nexus-5-l][OGA only]
Note: Music app with new architecture is currently under works in dev_apps folder and will have this issue fixed there. Once everything looks good with this new music app, the plan is to replace apps/music with it.  Since this bug affects the apps with old architecture only, we plan to wait for a couple of more sprints to address this and if it is still required to be fixed. 

Thanks
Hema
I recently addressed this in Music NGA as part of Bug 1206224. However, in my testing, I was actually unable to reproduce this issue in the old Music app. Can you confirm that this is still reproducible?
Flags: needinfo?(yue.xia)
Hi Justin,
I still can reproduce this problem in the old Music app on latest build of Flame 2.2/2.5. 
Please see attachment: Repro video_Flam 2.2.3gp
Rate: 5/5

Device info:
Flame v2.2 Build ID: 20150920032503
Flame v2.5 Build ID: 20150920150205

Thanks.
Flags: needinfo?(yue.xia)
blocking-b2g: 2.5+ → -
minus it because this is an OGA only music bug. 

New music app with NGA is live in apps/music folder. Old app bugs will no longer block. we will mark this WONT FIX when 2.5 is live
Un-assigning this since this is now OGA-only.
Assignee: jdarcangelo → nobody
OGA-only -> WONTFIX
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.