[STK]Press Home button to back to Homescreen, the STK dialog will be closed, but after a while, it will pop up again.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
9 months ago

People

(Reporter: yue.xia, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8626476 [details]
logcat_Flame3.0_1428.txt

[1.Description]:
According to comment 13 in bug 1079791, this bug is filed.
[STK][Flame v2.2&v3.0][N5 v2.2&v3.0]Enter STK menu screen, bring up some STK dialog, press Home button to go back to Homescreen, the STK dialog will be closed, but after a while, it will pop up again.
Found time: 14:28
See attachment: logcat_Flame3.0_1428.txt & STKdialog_video.3gp

[2.Testing Steps]: 
Precondition: Insert a CU SIM card in device.
1. Launch Settings app.
2. Scroll to the bottom of screen.
3. Tap the option under Operator Services.
4. This step depends on the menus, but access any menu which displays a STK dialog (with ok and cancel buttons, for example)
5. Press Home button.

[3.Expected Result]: 
5. Device go back to Homescreen. STK dialog is closed and could not pop up again.

[4.Actual Result]: 
5. Device go back to Homescreen, and the STK dialog will be closed. But after a while, it will pop up again.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150624162504
Gaia Revision          1f8981d7872e3c0053571c26fb3edaf401844d75
Gaia Date              2015-06-19 13:22:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2f8b845e5fa3
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150624.195750
Firmware Date          Wed Jun 24 19:58:02 EDT 2015
Bootloader             L1TC000118D0


Flame 3.0 version(Affected)
Build ID               20150624080416
Gaia Revision          eb0d4aefa62b20420d6fa0642515a110daca5d97
Gaia Date              2015-06-24 01:48:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4cdc1a95a672
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150624.153831
Firmware Date          Wed Jun 24 15:38:44 EDT 2015
Bootloader             L1TC000118D0

N5 2.2 version(Affected)
Build ID               20150625162500
Gaia Revision          1f8981d7872e3c0053571c26fb3edaf401844d75
Gaia Date              2015-06-19 13:22:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2f8b845e5fa3
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150625.212626
Firmware Date          Thu Jun 25 21:26:45 EDT 2015
Bootloader             HHZ12f

N5 3.0 version(Affected)
Build ID               20150625160206
Gaia Revision          038e917076271d304b906a41b4de670e505c67ae
Gaia Date              2015-06-25 00:22:19
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0b2f5e8b7be5
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150625.192222
Firmware Date          Thu Jun 25 19:22:41 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
This Problem can be reproduced via CMCC SIM card, but the phenomenon is a little different: press Home button to back to Homescreen from STK dialog. After a while, the menu screen will pop up(The previous view of STK dialog).
(Reporter)

Comment 1

4 years ago
Created attachment 8626482 [details]
STKdialog_video.3gp
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Bevis, not sure if you are owner. Could you help here?
Flags: needinfo?(btseng)
(In reply to Hermes Cheng[:hermescheng] from comment #2)
> Bevis, not sure if you are owner. Could you help here?

Hi,

From the log printed in Gaia, it seems more likely to be expected behaviour in Gaia in this scenario.
Because, when STK sends a DISPLAY_TEXT request and waiting for the response.
There is no response from user and the response was triggered by timer with result code set to STK_RESULT_NO_RESPONSE_FROM_USER. [1] 

That's why the STK send another DISPLAY_TEXT request again.

If this is not an expected behavior, Gaia has to send positive response to STK after user press the home button.

[1] https://github.com/mozilla-b2g/gaia/blob/a80c017c06acee175f911419a2c60c5cb76a37c3/apps/system/js/icc_worker.js#L280-L301
--

06-26 14:29:26.055 I/GeckoDump(  206): [system] STK_CMD_DISPLAY_TEXT callback for {"commandNumber":1,"typeOfCommand":33,"commandQualifier":129,"options":{"text":"欢迎使用联通《体坛快讯》业务,资费0.3元/次,不含通信费。客服:4006117878。确认点播?","isHighPriority":true,"userClear":true,"responseNeeded":false}}

06-26 14:29:26.055 I/GeckoDump(  206): [system] No response from user (Timeout)

06-26 14:29:26.055 I/GeckoDump(  206): [system] sendStkResponse to message: {"iccId":"89860112881039973648","command":{"commandNumber":1,"typeOfCommand":33,"commandQualifier":129,"options":{"text":"欢迎使用联通《体坛快讯》业务,资费0.3元/次,不含通信费。客服:4006117878。确认点播?","isHighPriority":true,"userClear":true,"responseNeeded":false}}}

06-26 14:29:26.055 I/GeckoDump(  206): [system] STK sendStkResponse -- # response = {"resultCode":18}

06-26 14:29:26.055 I/GeckoDump(  206): [system] ICC Getting ICC for 89860112881039973648

06-26 14:29:26.255 I/GeckoDump(  206): [system] STK Proactive Command for SIM 89860112881039973648: {"commandNumber":1,"typeOfCommand":33,"commandQualifier":129,"options":{"text":"欢迎使用联通《体坛快讯》业务,资费0.3元/次,不含通信费。客服:4006117878。确认点播?","isHighPriority":true,"userClear":true,"responseNeeded":false}}

06-26 14:29:26.255 I/GeckoDump(  206): [system] STK_CMD_DISPLAY_TEXT:{"text":"欢迎使用联通《体坛快讯》业务,资费0.3元/次,不含通信费。客服:4006117878。确认点播?","isHighPriority":true,"userClear":true,"responseNeeded":false}
Flags: needinfo?(btseng)
Flags: needinfo?(anygregor)
Fernando, can you take a look here?
Flags: needinfo?(anygregor) → needinfo?(frsela)
When you press the HOME BUTTON, we inform the SIM that the message wasn't processed by the user and had been closed. [1]

The SIM STK app will decide to retry showing the message until the user accepts or rejects it.

From my point of view, this is the correct way of working, if the STK message is important the STK app will show it until the user attends it and no accept ignoring it

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/js/icc.js#L174
Flags: needinfo?(frsela)

Comment 6

9 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.