Closed Bug 1177723 Opened 4 years ago Closed 4 years ago

Remove remaining database system search integration

Categories

(Firefox for Android :: Data Providers, defect)

41 Branch
All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 42
Tracking Status
firefox39 + fixed
firefox40 + fixed
firefox41 + fixed
firefox42 + fixed
fennec 39+ ---

People

(Reporter: rnewman, Assigned: rnewman, NeedInfo)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Following on from Bug 1111221, we should additionally remove search_suggest_query stuff from BrowserProvider and its manifest entry.
Figure I might as well upload this.
Attachment #8628074 - Flags: review?(mark.finkle)
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
Attachment #8628074 - Flags: review?(mark.finkle) → review+
Looks like this might need to chase Bug 1111221; initial test results from partner were wrong.

Try build: 

https://treeherder.mozilla.org/#/jobs?repo=try&revision=1b8565ac4c81
Also if this works, I owe mfinkle a hat-eating.
tracking-fennec: --- → 39+
Comment on attachment 8628074 [details] [diff] [review]
Remove remaining database system search integration. v1

Risk is relatively low in my opinion and mfinkle's.

Already asked kbrosnan if he can verify the try push. Nothing in that should be affected by release flags, so if everything works the findings should apply to release.

We can point the partner at that build and reverify, if we have time before 39 release, or we can ship and follow up.
Flags: needinfo?(mconnor)
Flags: needinfo?(kbrosnan)
Attachment #8628074 - Flags: approval-mozilla-release?
Attachment #8628074 - Flags: approval-mozilla-aurora?
OK, tracking for everything. This is a followup from bug 1111220 and is important for a partner distribution. We may need to build fennec 39 again if this fix holds.
Explanation of what's going on, as far as I understand it:

With Fennec installed, a device fails the Google Services Test Suite.

It fails in testWidgetPresence:


Launcher from package com.android.systemui does not contain search widget provided by com.google.android.googlequicksearchbox (Google App)


This system functionality was removed in Android 4.mumble. My impression, then is that this is an Android bug: our manifests support the system search widget on earlier Androids, and so we're causing a load that the harness no longer expects.

Each of these two fixes remove another chunk of that search functionality. If this doesn't do it, I'll need to request access to GSTS to debug further.
Main areas to verify: that we don't painfully regress any system search stuff in GB (probably not because we removed it?), and that basic smoketests (saving history, recording searches from Search Activity) are all green everywhere.
Am I waiting for verification on the fix before we rebuild?
Or should I be rebuilding fennec 39 now?

I can start such a build either before 4pm or so pacific time, or maybe very late tonight. I can also set it up in ship-it and someone else can put in the correct changeset if it's ready tonight and needs to happen.
Flags: needinfo?(rnewman)
We can rebuild now. I would encourage us to wait for Kevin's verification before pushing builds out, though!
Flags: needinfo?(rnewman)
This looks good manually. Tested on a Android 5.0, 4.4 and 2.3 device. Filed a few bugs but they are not regressions from this.
Flags: needinfo?(kbrosnan)
Thanks, Kevin.

Liz: patch is attached to this bug, and applied cleanly to mozilla-release when I pushed to Try. I'll check in later tonight to see if I can help with anything.
https://hg.mozilla.org/mozilla-central/rev/a11965c0a317
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Comment on attachment 8628074 [details] [diff] [review]
Remove remaining database system search integration. v1

Approved for uplift to aurora and release.
Comment on attachment 8628074 [details] [diff] [review]
Remove remaining database system search integration. v1

Actually this needs to uplift to 39 (on m-r) 40 (on m-b) and 41 (m-a) since we did the merge already.
Attachment #8628074 - Flags: approval-mozilla-beta+
Attachment #8628074 - Flags: approval-mozilla-release?
Attachment #8628074 - Flags: approval-mozilla-release+
Attachment #8628074 - Flags: approval-mozilla-aurora?
Attachment #8628074 - Flags: approval-mozilla-aurora+
Depends on: 1111220
You need to log in before you can comment on or make changes to this bug.