Status

Core Graveyard
GFX
P4
normal
RESOLVED WONTFIX
16 years ago
3 years ago

People

(Reporter: uamjet602, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Can't reproduce, URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6+) Gecko/20011218
BuildID:    2001121821

The page at the URL consists of a lot of questions. They have all been formatted
in the same way.

Now when you select a part (or the whole) of question 12.3, that line turns
black. This doesn't happen for the other lines.

Reproducible: Always
Steps to Reproduce:
1. Go to the page and scroll down to question 12.3, (who or what) has produced
an aviation manual
2. Select some or all of the text in that question.
3. Select some text in other questions

Actual Results:  The selection in question 12.3 makes it turn black. The other
lines work normal.

Expected Results:  Do like the other lines, or at least be somewhat consistent.

If you look at the source, you'll see that every line is the same html (the
content is one long line actually). I can't see why this line works different
from the others.

btw. there are some answers to the questions on www.nat.org :)

Comment 1

16 years ago
hmm linux maybe? akkana i am giving this to you.  on windows it looks great.  
If this happens on linux maybe you know who to give this to...
Assignee: mjudge → akkana

Comment 2

16 years ago
The lines all look the same to me, on linux, including 12.3 ("has produced an
aviation manual?") and they all select in the same color.  I have no idea what
you're seeing.  Can you be more specific?

Comment 3

16 years ago
Same here for me, I do not see any weird behavior with linux build
2002-03-01-09-trunk, closing as WFM, please reopen if you can still reproduce?
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

16 years ago
Created attachment 72574 [details]
screenshot of problem on linux 2002022121

I've attached a screenshot of what happens. This is with Linux build 2002022121
though. I'll check with a newer build later.
(Reporter)

Comment 5

16 years ago
Still happens for me on 2002030511 Linux -> reopening

Could someone give me a hint on how I could provide you with more information?
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 6

16 years ago
At this point, it only seems to be happening for one person, which suggests that
there's something unusual about your environment.  Unless we can narrow it down
and find out how to reproduce it, we can't find out why it's happening and
assign it to a person who can fix it.  Try it on other machines if you have any
available, or see if it happens for other people you know -- if you can find
another machine which sees it maybe that will suggest what the difference is.

Also, try renaming your .mozilla directory and starting again with a new
profile, and see if it still happens.  (If not, then it's something in your
profile, so you can start renaming files selectively, removing parts of files,
etc. to find the culprit.)  Or, easier, try logging in as a different user on
the same machine, under a different desktop envioronment (e.g. try gnome instead
of kde or vice versa) and see if that makes a difference.
Whiteboard: Can't reproduce

Comment 7

16 years ago
I'm afraid I have to mark this worksforme, unless we can turn up anyone else who
also sees the problem and ty to find some commonality between the setups.  If
you get a chance, try some of the things I suggested to try to pin this down,
and if you can figure out what's causing it and it's a mozilla bug, by all means
reopen.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 8

16 years ago
I can confirm this bug on Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:0.9.9)
Gecko/20020320, same hardware but running FreeBSD-4.5-STABLE.

The effect appears randomly on the page though, not necessarily with the same
question (this time it was around question 14.6).

2 options remaining: either XFree is messing up the video for this particular
card (on both Linux & FreeBSD), or mozilla still has a bug in its rendering
engine. Video hardware used: intel i815 from a Dell Optiplex GX-115.
(Reporter)

Comment 9

16 years ago
Hmmm.. Turns out I didn't look hard enough.

I can now reproduce on a completely different machine, running Mozilla 0.9.7
(yes I know it is old :) 

This machine is running RedHat linux 7.1, and contains a S3 Inc.Savage 4
( Vendor id=5333. Device id=8a22 )

New steps to reproduce:

1. Go to the page.
2. Click in the page and drag down, moving the mouse up and down as you go to
see what happens when lines get selected/deselected.
3. Look closely for drawing errors. The exact line that this happens at changes
with os, machine, mozilla release and the phase of the moon.
4. Notice that one or two lines will mess up. 
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 10

16 years ago
Aha!  Yes, I see it now -- thanks for the good explanation on how to reproduce
it.  Once I scrolled down far enough that I got a messed-up ilne, if I force a
redraw (i.e. cover it with a menu or another window, then uncover it), it draws
correctly the second time.

In other words, this sounds like a bug in rendering (compositor).  Reassigning
to someone who might be able to debug this; cc'ing Mike (who has at least looked
at the selection rendering code), Kin (who knows about the autoscroll code in
case that might be part of the problem here), and blizzard and pavlov (who know
a bit about our rendering in gtk and might be able to suggest something).
Assignee: akkana → kmcclusk
Status: REOPENED → NEW
Component: Selection → Compositor
QA Contact: tpreston → petersen
(Assignee)

Updated

16 years ago
Priority: -- → P4
Target Milestone: --- → Future
(Reporter)

Comment 11

16 years ago
Another page where something that looks a lot like this happens is:

http://www.dansdata.com/sbs3.htm

I get corruption when I select the beginning of this paragraph:

'When replacing screws, remember to tighten everything as if the computer were a
major structural component of the Sydney Harbour Bridge. Overtightening screws
increases the chance of reaming the.....'

- You don't need to be autoscrolling for this to happen
- On this page, the badly drawn object is not in a <ol> list.
- The place where this happens changes with the width of the browser window.
When I resize the window to be smaller, it happens lower in the page.
Product: Core → Core Graveyard
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 16 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.