"File could not be sent" when sharing via bluetooth

RESOLVED INVALID

Status

Firefox OS
Gaia::Bluetooth
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: myk, Unassigned)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bzlite])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

My Aries Spark device is connected to my laptop via Bluetooth, but when I try to share a file (an image from the gallery), the device first notifies me that "The transfer has started" and then that "File could not be sent." My laptop never prompts me to accept the file, as it does when I share a file via Bluetooth on my Flame devices running FxOS 2.x.
I tried sharing files to iOS and OSX. While paring worked both transfers failed in a similar manner.
Flags: needinfo?(nhirata.bugzilla)
(Reporter)

Comment 2

3 years ago
Created attachment 8628336 [details]
bluetooth-log.txt

I too tried to transfer files to Mac OS X (10.10.3).  I initiated the transfer on the Aries.  Here's an adb logcat log of messages containing "bluetooth" during a transfer attempt.
Jocelyn, fyi.
Flags: needinfo?(nhirata.bugzilla) → needinfo?(joliu)
Hi Myk,

I couldn't reproduce this using my aries and Mac OS X (10.10.3).
Transfer works correctly on my devices.
Is it always reproducible?
Have you try to transfer files to other devices or other OSs?

Thanks,
Jocelyn
Component: Gaia::Feedback → Gaia::Bluetooth
Flags: needinfo?(joliu)
(In reply to Harald Kirschner :digitarald from comment #1)
> I tried sharing files to iOS and OSX. While paring worked both transfers
> failed in a similar manner.

Hi Harald,

For iOS, from my understanding, this is the expected behavior since there was a restriction on iOS which disallows the transfer.

For OSX, I can successfully transfer files from my aries to it, could you go to "System Preference" - "Sharing" and check if Bluetooth Sharing is On as attached image?
Have you try other devices? Can it transfer to your OSX successfully?

Thanks,
Jocelyn
Flags: needinfo?(hkirschner)
Created attachment 8628622 [details]
bluetooth sharing setting on OSX

Updated

3 years ago
See Also: → bug 1180796
QA Whiteboard: [foxfood-triage]
Worked for me with the new settings. Thanks!
Flags: needinfo?(hkirschner)

Comment 8

3 years ago
ni? Myk as well.

Myk, what OS does your laptop use? Please confirm whether bluetooth sharing is enabled as comment 5 if you use Mac OS. More details are stated on wiki [1].

[1] https://wiki.mozilla.org/B2G/Bluetooth#FAQ

==
5. Why can't I send a file to or receive a file from my Mac?

    If you would like to share files to Mac, the file-transfer function should be enabled beforehand. 

    1. Click the Bluetooth icon at the top-right corner of the screen 
    2. Select "Open Bluetooth Preferences" from the drop down menu, then click the "Sharing Setup..." button at the bottom right of the dialog that opens 
    3. Make sure the "Bluetooth Sharing" checkbox is enabled. 

    Please see https://support.apple.com/kb/PH18969 for more information.
Flags: needinfo?(myk)
Keywords: foxfood
Keywords: dogfood
(Reporter)

Comment 9

3 years ago
(In reply to Ben Tian [:btian] from comment #8)
> Myk, what OS does your laptop use? Please confirm whether bluetooth sharing
> is enabled as comment 5 if you use Mac OS. More details are stated on wiki
> [1].

My laptop uses Mac OS X 10.10.  I just checked the Bluetooth Sharing preference, and it was disabled, which must've happened when I recently upgraded to a new laptop (and from 10.9 to 10.10).

After I enabled the preference, file sharing worked correctly.  So this turns out to be user error.  My bad!  And thanks for the references to the docs.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(myk)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.