bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Scrollbar locks when page with viewpoint plugin is resized and when I try to scroll

VERIFIED DUPLICATE of bug 110094

Status

()

Core
Plug-ins
VERIFIED DUPLICATE of bug 110094
17 years ago
17 years ago

People

(Reporter: shrirang khanzode, Assigned: av (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
seen on 0101 0.9.4 branch build.

steps:
download and install viewpoint plugin as mentioned in bug 116108.
Go to the url above
Resize the page so that the vertical scrollbar appears.
With the mouse, try to scroll down..observe that scrollbar gets locked.

After you click once inside the content area, and then try, scrolling 
works..however the content does not lay out properly...( cube disappears and 
appears messed up). After I resize the page, things paint correctly.
(Reporter)

Comment 1

17 years ago
one more thing, if you can scroll during the first instance, pls click inside 
the plugin area once and then try to scroll again.You should see the locking 
problem I mentioned. 

Comment 2

17 years ago
I think this is related to something I have been looking into today:
As soon as you click into the plugin window once, ALL MOUSE EVENTS (probably 
includes this scrolling problem, also clicking on buttons or just clicking 
elsewhere on the page) get sent to the plugin.
I think the reason is that we steal the mouse capture and release it when the 
button is released (on WM_LBUTTONUP).  But this means that you never get the 
BUTTON UP message yourself.
I am trying to send it on to you- that may clear up some of thse problems.

Comment 3

17 years ago
I put up a new version of the plugin that should fix the problem where the 
scroll bar gets locked.  The paint problem is still there- I'll look at that 
next. The URL for the plugin is:
http://cole.viewpoint.com/~aberger/npViewpoint.dll
(I have not uploaded an installer with the new dll yet).

Comment 4

17 years ago
Is this the same painting bug as was marked fixed in bug 116108?
It looks to me like both say that if you change the position of the 
plugin/scroll the page, it doesn't get redrawn correctly.  It was marked fixed 
there but it looks broken to me.  Is this the same problem?
Am I correct to expect SetWindow calls as the page gets scrolled? I don't get 
any.
(Reporter)

Comment 5

17 years ago
I think...116018 was about the ' window resize' problem. This one is about 
'scroll'. Andrei had mentioned/asked about  this in bug 114667 here

------- Additional Comment #27 From Andrei Volkov (av) 2001-12-19 15:36 -------
(Reporter)

Comment 6

17 years ago
guess this is edt material. Nominating...
Keywords: edt0.9.4

Comment 7

17 years ago
Is this - bug 110094 - the scrolling bug that you are looking for?

Comment 8

17 years ago
I agree with David that the remaining part of this bug is a duplicate of bug 
110094.  That is assuming that the first part of the bug (scrollbar getting 
locked) is seen fixed in the current version of our plugin.  I tested it- it 
seems to be OK.  If you agree that it no longer locks, and that the only 
problem is that we don't preserve our position when scrolled, then this should 
probably be marked duplicate of 110094.
If you still see the scrollbar locking, please let me know.
(Reporter)

Comment 9

17 years ago
y'sir, just verified that the scrollbar no longer locks in 0106 0.9.4 branch 
build and using your latest plugin. Marking dup of 110094. Thx! I see a new 
problem with the mouse pointer, filed as bug 118642

*** This bug has been marked as a duplicate of 110094 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 10

17 years ago
Removing KW
Keywords: edt0.9.4
(Reporter)

Comment 11

17 years ago
vd
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.