SeaMonkey Blog: Pictures in comments will be lost after submission

RESOLVED WONTFIX

Status

--
minor
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: RainerBielefeldNG, Unassigned)

Tracking

Details

(Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/1582] , URL)

(Reporter)

Description

3 years ago
Steps how to reproduce:
1. Log in for <https://blog.seamonkey-project.org/>
2. find one of your comments (or submit a comment for this test)
3. click 'edit' below comment
   » edit window opens
3. click behind end of text  → Click [img] - button above text area
   → Into upcoming input dialog insert a picture URL like <http://www.seamonkey-project.org/images/template/header-logo.png>  → 
    [ok] → insert description → [ok]
   » Trailing code "<img src="http://www.seamonkey-project.org/images/template/header-logo.png" alt="Test" />" will be added
4. blue [Update]
   » Message view appears
   Bug: Picture is missing
5. Redo Step 3
   Bug: Picture code has vanished completely.

a) It might be intended not to allow pictures, but in that case there should not be an 'insert image' button.
b) might be a WORDPRESS bug?

Comment 1

3 years ago
Cc: mcsmurf
Summary: Blog: Pictures in comments will be lost after submission → SeaMonkey Blog: Pictures in comments will be lost after submissionmc

Updated

3 years ago
Flags: needinfo?(bugzilla)
Good question, not sure what's going on here. If I had to guess then I would say that pictures are not allowed in comments. As far as I see this the problem only affects people like you or myself as the others cannot log in and so also cannot change their comments? So probably this bug has a quite low priority, but I can see if I can find out more.
Flags: needinfo?(bugzilla)

Updated

3 years ago
Flags: needinfo?(bugzilla)
(Reporter)

Comment 3

3 years ago
(In reply to Frank Wein [:mcsmurf] from comment #2)
> So probably this bug has a quite low priority, but I can see if I can
> find out more.

The problem also affects users who have a little WORDPRESS- (and/or) Experience who know that you can use an arbitrary WORDPRESS account , SM or HTML-Knowledge) to create comments with some formatting and pictures.
But yes, of course this one only has a low priority.
Severity: normal → minor

Updated

3 years ago
Summary: SeaMonkey Blog: Pictures in comments will be lost after submissionmc → SeaMonkey Blog: Pictures in comments will be lost after submission
Jason: Not sure if you are the right contact for my question, but do you or one of your colleagues know if pictures inside comments have been disabled on https://blog.seamonkey-project.org/? That setting itself is fine, just wondering because the Wordpress UI offers to insert images in comments (which then disappear when submitting the comment).
Flags: needinfo?(jcrowe)

Comment 5

3 years ago
(In reply to Frank Wein [:mcsmurf] from comment #4)
> Jason: Not sure if you are the right contact for my question, but do you or
> one of your colleagues know if pictures inside comments have been disabled
> on https://blog.seamonkey-project.org/? That setting itself is fine, just
> wondering because the Wordpress UI offers to insert images in comments
> (which then disappear when submitting the comment).

I am not working on this project any longer and am not sure what may have changed recently. I will go ahead and move this bug over to a webops component to see if they can assist you.
Assignee: nobody → server-ops-webops
Component: Project Organization → WebOps: IT-Managed Tools
Flags: needinfo?(jcrowe)
Product: SeaMonkey → Infrastructure & Operations
QA Contact: smani
Version: unspecified → other

Updated

3 years ago
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/1582]

Comment 6

3 years ago
According to this link from Wordpress:
   https://en.forums.wordpress.com/topic/how-to-insert-a-picture-directly-in-a-comment
... it is a Wordpress bug.  [1]  It doesn't sound like they are interested in fixing it:
    camaleonx: [...] My question is: If no image can be added to comments... why in the box to 
        edit a comment exist a button to add an image? (!)
    thesacredpath: "It's a mistake that the image button is there. The HTML code to display an
        image in a post will always be stripped out. "

A different link:
   https://en.forums.wordpress.com/topic/insert-picture-in-comments
... mentions that:
"The Admin of a WordPress.com blog, or Authors and Editors can insert images into their comments. Also your readers can post links to their images wherever they are hosted online, then you can edit their comments to insert the image/images yourself when you approve comments if you wish to. "

Based on earlier discussion in that link, readers may post links to images already hosted elsewhere (not upload them) but that they may require editor approval.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 7

3 years ago
(In reply to C. Liang [:cyliang] from comment #6)
You are right - I should have checked that.

It is possible to insert pictures from web-sources, as can be seen here <https://seamonkeyde.wordpress.com/2015/08/13/neu-lokalisierte-win32-nightly-builds-seamonkey-2-37-2015-07-13-0708-viele-sprachen/comment-page-1/#comment-70>, that's sufficient.

Updated

3 years ago
Flags: needinfo?(bugzilla)
(Reporter)

Comment 8

3 years ago
Forget my comment 7, seems to be nonsense.

Inserting pictures works fine at wordpress.com (<https://seamonkeyde.wordpress.com/2015/08/13/neu-lokalisierte-win32-nightly-builds-seamonkey-2-37-2015-07-13-0708-viele-sprachen/comment-page-1/#comment-72>, but fails on <https://blog.seamonkey-project.org/>

I wonder whether the cited forum page is related to the problem. Some time ago when I tried to solve an other problem with my blogs <https://de.forums.wordpress.com/topic/einbindung-von-fallingrain-wettergraphen-funktioniert-nicht-mehr?replies=3#post-32703> (German) I was told that there is a strict difference between support / forum responsibility for  wordpress.com server or wordpress.org software.

Here <https://wordpress.org/support/topic/add-images-to-comments> I found a discussion concerning problems with comment system "jetpack", where I read that without using jetpack it should be possible to add pictures.

I also found
<https://wordpress.org/support/topic/can-pictures-be-posted-in-comments#post-552631>
<https://wordpress.org/support/topic/upload-images-to-comments>
<https://wordpress.org/support/topic/plugin-to-allow-users-to-add-a-photo-in-their-comment>
and Plugins <https://wordpress.org/plugins/comment-images/>, 

All that makes me sure that it IS possible to allow comments in self hosted owrdpress blogs; but as long as I am the only one who is interested in that feature we can leave this one WONTFIX.
You need to log in before you can comment on or make changes to this bug.