All users were logged out of Bugzilla on October 13th, 2018

its nearly impossible to left drag from email app

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 years ago
8 months ago

People

(Reporter: surkov, Unassigned)

Tracking

({foxfood})

unspecified
foxfood

Firefox Tracking Flags

(blocking-b2g:2.5+)

Details

(Whiteboard: [bzlite])

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Try to left drag email app to switch to previous app in the queue. Emails are scrolled up down but app is not switched
(Reporter)

Comment 1

3 years ago
Same in bugzilla light app. If dragging doesn't start from 0 pos then app switch doesn't work. it works ok for right drag. Perhaps the issue is related with list view that both apps have
Keywords: foxfood
Keywords: dogfood
blocking-b2g: --- → 2.5+
QA Whiteboard: [foxfood-triage]
Component: Gaia::Feedback → Gaia::System
Seems to work fine for me, actually.
Component: Gaia::System → Gaia::System::Window Mgmt
(Reporter)

Comment 3

3 years ago
(In reply to Martijn Wargers [:mwargers] (QA) from comment #2)
> Seems to work fine for me, actually.

Yes, if I do the drag from the start. If there's non zero offset from the start then drag doesn't work. That would be possibly ok, the users could learn that, but it seems there's a certain difference if you do a drag from left vs right. Right drag is not so crucial for non zero offsets.
Can we get a video here to see whats working and whats not working?
Keywords: qawanted
I was unable to reproduce this issue on either Flame or Aries devices runnng the latest build.  Leaving the tag for someone else to try.

Reporter can you provide a build id to possibly help with reproduction?

Environmental Variables:
Device: Aries 2.5
BuildID: 20150725011637
Gaia: ade1ef5249cfab921e00ed67b30f3d03c2e24b5e
Gecko: d3228c82badd
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20150727071247
Gaia: ade1ef5249cfab921e00ed67b30f3d03c2e24b5e
Gecko: 27ae736ef960
Version: 42.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Flags: needinfo?(surkov.alexander)
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)

Comment 6

3 years ago
I was unable to reproduce this issue on today's Flame or Aries devices runnng the latest build. I also attempted a central build around reported date for Flame. Leaving the tag for someone else to try.

Environmental Variables:
Device: Aries 2.5 Kk
Build ID: 20150727151800
Gaia: 4e3e21a4ba3f188b45623ee2297f21d0791f8667
Gecko: 21ca97268bae
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Environmental Variables:
Device: Flame 2.5 kk Full Flash (319mb)
BuildID: 20150629010206
Gaia: 8a1e4ae522c121c5cacd39b20a5386ec9055db82
Gecko: eaf4f9b45117
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 41.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Environmental Variables:
Device: Flame 2.5 kk Full flash (512mb due to Email closing out on 319mb for this build)
Build ID: 20150727074921
Gaia: 4e3e21a4ba3f188b45623ee2297f21d0791f8667
Gecko: 21ca97268bae
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
QA Whiteboard: [foxfood-triage] → [QAnalyst-Triage?][foxfood-triage]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][foxfood-triage] → [foxfood-triage]
Flags: needinfo?(ktucker)
I also cannot reproduce this issue. I see no difference dragging from left-to-right or right-to-left in email app. I was able to consistently dragging to previous or next app using edge gesture. 

If reporter is still reproducing this issue on latest, please provide a video. We're removing qawanted tag due to inability to reproduce the issue between multiple testers.

Device: Aries (RC4 and OTA'ed to latest)
BuildID: 20150729013848
Gaia: 21256d7665f972255d198f8af81a8df4bd0e0fc4
Gecko: 2ee9895e032c
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5 Master) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
QA Whiteboard: [foxfood-triage] → [foxfood-triage], [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [foxfood-triage], [QAnalyst-Triage?] → [foxfood-triage], [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
WFM according to comments above.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

8 months ago
cancel ni? per comment 8
Flags: needinfo?(surkov.alexander)
You need to log in before you can comment on or make changes to this bug.