Closed Bug 1178083 Opened 6 years ago Closed 6 years ago

Fetch function names for hang stacks - not working

Categories

(Toolkit :: Telemetry, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla44
Tracking Status
firefox42 --- affected
firefox44 --- fixed

People

(Reporter: guijoselito, Assigned: vladan)

References

Details

Attachments

(1 file, 1 obsolete file)

STR:
1 - hang your browser somehow
2 - open about:telemetry and click on Browser Hangs
3 - click on the blue "Fetch function names for hang stacks"

Expected results:
the numbers are changed by something else

Actual results:
nothings happens - after a few minutes it says there was a network error.
I think this is a dupe; we've been having lots of problems with the symbolication server as of late.
Flags: needinfo?(vdjeric)
It turns out the server's SocketServer library wasn't killing connection threads, so the symbolication server ended up using 526 threads and 18GB of resident memory before I killed the server.

I restarted it for now, but I'm going to rewrite the server using Flask this week.
Flags: needinfo?(vdjeric)
Right now, after I click on "Fetch function names for hang stacks" everything there disappears and

"17:28:00.106 TypeError: aPing.payload is undefined
ChromeHangs_renderHangHeader() aboutTelemetry.js:903
SymbolicationRequest_handleSymbolResponse() aboutTelemetry.js:851
1 aboutTelemetry.js:903:9"

shows up on the Browser Console.
Attached patch fixSymbolication.patch (obsolete) — Splinter Review
Quick fix, I'll have to rebase this patch
Attachment #8673952 - Flags: review?(gfritzsche)
Attachment #8673952 - Flags: review?(gfritzsche) → review+
Ready for checkin
Attachment #8673952 - Attachment is obsolete: true
Attachment #8674379 - Flags: review+
Keywords: checkin-needed
Assignee: nobody → vladan.bugzilla
https://hg.mozilla.org/mozilla-central/rev/1b3332a39744
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Duplicate of this bug: 1181024
You need to log in before you can comment on or make changes to this bug.