Intermittent test_cache_orphaned_body.html,test_cache_orphaned_cache.html | disk usage should return to original - got 65536, expected 65842

RESOLVED FIXED in Firefox 41

Status

()

Core
DOM
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Tomcat, Assigned: bkelly)

Tracking

({intermittent-failure})

unspecified
mozilla42
intermittent-failure
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox40 unaffected, firefox41 fixed, firefox42 fixed, firefox-esr31 unaffected, firefox-esr38 unaffected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=3584258&repo=fx-team

19:03:39 INFO - 1450 INFO TEST-UNEXPECTED-FAIL | dom/cache/test/mochitest/test_cache_orphaned_body.html | disk usage should return to original - got 65536, expected 65842
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

3 years ago
Assignee: nobody → bkelly
Status: NEW → ASSIGNED
(Assignee)

Comment 4

3 years ago
Created attachment 8627333 [details] [diff] [review]
Fix race in Cache API orphaned data tests. r=ehsan

I think this intermittent is caused by the same thing as bug 1168152 comment 20.  Basically I need an extra operation between running caches.delete() and resetting the storage to measure its size.

Try build (with code changes in the try patch itself):

https://treeherder.mozilla.org/#/jobs?repo=try&revision=fdf959aea2a5
Attachment #8627333 - Flags: review?(ehsan)
Summary: Intermittent test_cache_orphaned_body.html | disk usage should return to original - got 65536, expected 65842 → Intermittent test_cache_orphaned_body.html,test_cache_orphaned_cache.html | disk usage should return to original - got 65536, expected 65842
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

3 years ago
Attachment #8627333 - Flags: review?(ehsan) → review+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/e34973a9142a
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox42: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
status-firefox40: --- → unaffected
status-firefox41: --- → affected
status-firefox-esr31: --- → unaffected
status-firefox-esr38: --- → unaffected
https://hg.mozilla.org/releases/mozilla-aurora/rev/a627cb75c001
status-firefox41: affected → fixed
Flags: in-testsuite+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.