moving large amounts of mail leads to data corruption

RESOLVED WORKSFORME

Status

MailNews Core
Backend
--
major
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: rolux, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 6/30)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122106

moving large amounts of mail from one folder to another is very broken in
numerous ways: data gets lost or is doubled, the application hangs or gives no
feedback, the given feedback is misleading, and essential features like locking
the mailbox or checking for disk space are missing.

Reproducible: Always
Steps to Reproduce:
1. move a large amount of mail (like 1,000 messages, but can be less) from one
folder to another, either via drag and drop or via right click and move to.
2. if everything works fine, repeat step 1.

Actual Results:  the following problems appear (not necessarily in this order):

- moving messages is sometimes fast and sometimes very slow
- in the meantime, the text "moving message..." at the bottom bar sometimes
appears, sometimes does not appear at all, sometimes hangs after a certain
number of messages and sometimes disappears when the application tries to
receive new mail (indicating that the mailbox is not locked like it is when
building summary files)
- at the same time, the selected messages sometimes disappear one by one, but
sometimes do not - in this case they can be deselected, reselected, moved again,
moved elsewhere etc (without any feedback indication what the application is
actually doing)
- the messages will sometimes be moved, sometimes not be touched at all,
sometimes be copied (i.e. not deleted, which is almost impossible to detect
since the number of messages displayed for both folders does not change at all)
and sometimes be lost (especially if there is not enough disk space, which
shouldn't affect a _move_ operation)
- in some cases, the application will simply freeze
- restarting the application sometimes resets its behaviour to normal (for one
or more move operations), but more often does not

Expected Results:  NONE of the above, or a WARNING MESSAGE asking me to backup
my mailbox before moving more than 100 messages

moving a large amount of mail from a to b should not be considered extravagant.
it is a basic feature of any mail client, and an essential one for a mail client
that regularly has to rebuild mail folders and thus becomes almost unusuable
once the folders have reached a critial size (~10,000 messages).

the behaviour of the application adds to the feeling (which was common before
~0.9.2 and got more common again since ~0.9.5) that mozilla mail/news (even with
enough disk space and ram) is not a safe place for your mail and has to be used
with extreme caution, especially because user input often leads to delayed or no
feedback and the mail folders' display often does not correspond with their real
content - which is both an actual and a psychological blocker for the whole
application.

Updated

16 years ago
QA Contact: esther → sheelar

Comment 1

16 years ago
A major rewrite of move/copy code is due and could happen in next
few milestones. Is this imap, local, nntp or have you seen this 
behvaior for all three protocols. 





Assignee: sspitzer → naving
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

16 years ago
it's a pop account (and all operations were local, of course)

Updated

16 years ago
Component: Mail Window Front End → Mail Back End
(Reporter)

Comment 3

16 years ago
add to the list of problems:
- messages are sometimes complete and sometimes corrupted: only a part of the
message, the same part of the message repeated or two different messages mixed
- the number of messages figure for the destination folder can be very
misleading (apart from stay the same when it should change): in at least one
case, moving 12 messages to the trash folder lead to an increase of roughly
8,000 messages

Comment 4

16 years ago
Navin,
I think this is a dup of bug 113553 in general.  Although, this bug has a good
summary of all the problems relating to moving large mails.  But we do have
different bugs for each issue mentioned here.
I am not marking it a dup because you confirmed this bug and I am not sure how
you feel this is different from the ones we already have for moving mail
messages.  I will let you decide. 

Comment 5

16 years ago
bug 113553 is about just one case where we cannot delete message. This bug 
is more in general about reliability of move/copy. It may be helpful
if you can also reproduce what the reporter is seeing. I can imagine
stopping move/copy may not work smoothly but in general move/copy 
should work ok.

Updated

16 years ago
Severity: blocker → major

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 6

16 years ago
Created attachment 93275 [details]
screen dump of mailbox corruption

note that the msg selected in the list is not the msg displayed...perhaps
related to filtering or compaction?

also note the build: 1.1beta...

Comment 7

16 years ago
I just got bitten by this bug while testing nightly build 2002082008. I was
checking some table rendering issues and downloaded the latest nightly build to
check against. I didn't attempt to move a large amount of mail. I opened the
browser and selected preferences and then cleared the history and the cache. I
then launched Mail and was immediately prompted by the account wizzard to add a
new account. Interestingly all my mail accounts and newsgroups were gone (2 news
accounts, 2 pop accounts). When I checked the mail data files I could see data
for mail records in the Inbox, Sent and trash. I attempted to move over the
Inbox data file to a new account I created and Mail hung. Nothing worked and I
lost all my accounts. My backup was too old to recover from so I have been
reduced to picking data of the files using a text editor. ug.

Updated

15 years ago
QA Contact: sheelar → stephend

Updated

15 years ago
Flags: wanted1.3a+

Comment 8

15 years ago
Please do not set + on flags unless you are a driver. If you would like to
nominate the bug use ?.
Flags: wanted1.3a+

Comment 9

15 years ago
Navin, what's the bug # on this major rewrite? Has it been done already?
mass re-assign.
Assignee: naving → sspitzer
Status: ASSIGNED → NEW

Comment 11

14 years ago
I recently lost messages while reorganizing huge amounts of e-mail. I was either
using 1.5 or 1.6 final at the time in Win2K. It happened a number of times while
I was trying to reorganize. Some times Mozilla would just freeze, and I would
have to start over after finding out what copied and what didn't copy. And I had
to restore some mail from a backup copy.

I eventually switched to moving smaller quantities of messages, then finally
gave up because it was so much work, so my e-mail is not yet fully organized. I
have over 100 subfolders and well over 50,000 messages dating back to 1997 (My
older messages came from Netscape. I migrated from Netscape 4.7x to Mozilla back
at 1.0-RC?).

Good thing I back up my e-mail, but I would really like to feel safer about
reorganizing my Mozilla mail.
Product: MailNews → Core

Comment 12

11 years ago
Rolux and others, do you still see this problem?  (I would think the problems you were experiencing at that time are gone)
Whiteboard: CLOSEMEw 6/30

Comment 13

11 years ago
I'm not aware of this problem having happened to me in a long time, though I haven't done much moving of e-mail in a long time either.
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
I'm going to go ahead and close this bug as WORKSFORME. Eric, Rolux, and others, if you still see this or see it again, feel free to reopen (or comment if you're unable to reopen).
Whiteboard: CLOSEMEw 6/30 → CLOSEME 6/30
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.