Closed Bug 1178226 Opened 7 years ago Closed 6 years ago

[Settings]It will back to home page itself after choosing a wallpaper from Camera.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.2 unaffected, b2g-master affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: hedan, Assigned: gsvelto)

References

Details

(Keywords: regression, Whiteboard: [3.0-nexus-5-l])

Attachments

(2 files)

Attached video v3-0.3gp
[1.Description]:
[Flame v3.0]&[Nexus 5 v3.0][Settings]After choosing a wallpaper from Camera, device should back to Display page only. But actually it will  back to home page directly, or back to Display page for a short time and then back to home page itself.

Occur Time:12:03
Attachment:logcat1203.txt & v3-0.3gp

[2.Testing Steps]: 
1.Launch Settings.
2.Tap Display->tap the wallpaper thumbnail and choose Camera.
3.Take a photo and select it.

[3.Expected Result]: 
3.It shouldn't back to home page itself.

[4.Actual Result]: 
3.It will back to home page directly,or back to Display view for a short time and then back to home page itself.

[5.Reproduction build]: 
Device: Flame 2.2 (Unaffected)
Build ID               20150628002505
Gaia Revision          0179935627012dfde3ca036c9a71035be463b7ad
Gaia Date              2015-06-26 21:13:44
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/35e09270da3a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150628.035537
Firmware Date          Sun Jun 28 03:55:48 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150628160206
Gaia Revision          8a1e4ae522c121c5cacd39b20a5386ec9055db82
Gaia Date              2015-06-25 21:58:25
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/eaf4f9b45117
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150628.193057
Firmware Date          Sun Jun 28 19:31:08 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus5 2.2 (Unaffected)
Build ID               20150626162505
Gaia Revision          0179935627012dfde3ca036c9a71035be463b7ad
Gaia Date              2015-06-26 21:13:44
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/330f52ef6a2d
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150626.195122
Firmware Date          Fri Jun 26 19:51:42 EDT 2015
Bootloader             HHZ12f

Device: Nexus5 3.0 (affected)
Build ID               20150628160206
Gaia Revision          8a1e4ae522c121c5cacd39b20a5386ec9055db82
Gaia Date              2015-06-25 21:58:25
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/eaf4f9b45117
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150628.192615
Firmware Date          Sun Jun 28 19:26:32 EDT 2015
Bootloader             HHZ12f


[6.Reproduction Frequency]: 
occasionally Recurrence,3/5

[7.TCID]: 
Free Test

[8.Note]:
This issue does not occur when the Memory of device is 512 Mb or 1G.
Attached file logcat1203.txt
a regression? please help find regression-window
QA Contact: jthomas
b2g Inbound Regression Window

First Working

Environmental Variables
Device: Flame 2.5 
BuildID: 20150622170244
Gaia: c4d3b8fd78bcd7eff1b127060ec6490a891b7a35
Gecko: 2ab4034b2cc1
Version: 41.0a1 (2.5)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0



First Broken

Environmental Variables
Device: Flame 2.5 
BuildID: 20150623190325
Gaia: eb0d4aefa62b20420d6fa0642515a110daca5d97
Gecko: 5a3ee6baf143
Version: 41.0a1 (2.5)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0



First Working gaia / Last Broken gecko - This issue does NOT occur.
Gaia: c4d3b8fd78bcd7eff1b127060ec6490a891b7a35
Gecko: 5a3ee6baf143

Last Broken gaia / First Working gecko - This issue DOES occur.
Gaia: eb0d4aefa62b20420d6fa0642515a110daca5d97
Gecko: 2ab4034b2cc1

b2g Inbound Pushlog:
https://github.com/mozilla-b2g/gaia/compare/c4d3b8fd78bcd7eff1b127060ec6490a891b7a35...eb0d4aefa62b20420d6fa0642515a110daca5d97

This issue most likely occurs due to Bug 1144132
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Gerry, can you take a look at this or assign it to the correct person since the author is no longer available? This looks to have been caused by the landing for bug 1144132.
Blocks: 1144132
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(gchang)
Hi Gregor,
Can you help to dispatch to right owner?
Flags: needinfo?(gchang) → needinfo?(anygregor)
I'm investigating this since I'm the author of the gecko fix for bug 1144132 and I'm the most familiar with the underlying code.
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Flags: needinfo?(anygregor)
After a few tries I've managed to reproduce the issue, now investigating the underlying problem.
Is this still a problem?
Flags: needinfo?(gsvelto)
I've tried the STR ten times on a Flame in the 319 MiB configuration and I can't reproduce anymore. This was most likely caused by the Nuwa-related memory regressions we fixed last month. Closing as WFM.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(gsvelto)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.