JS Resource loader gets "undefined" when opening in new tab sometimes

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: john.duffell, Unassigned)

Tracking

38 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.130 Safari/537.36

Steps to reproduce:

Firefox: 38.0.5
Also nightly: 41.0a1 (2015-06-29)
1. Open our website http://www.theguardian.com/uk
2. open a story in a new tab
3. if the adverts appear, close the tab and return to step 2
4. if the adverts don't appear, you should see a console error 'n is undefined'


Actual results:

You will get a TypeError: n is undefined.
In this case, n is minified from "config" on this line:
https://github.com/guardian/frontend/blob/master/static/src/javascripts/projects/common/modules/experiments/ab.js#L114


Expected results:

The adverts and JS should have loaded, and config should have been defined.
We are using https://github.com/cujojs/curl to load our modules, but the problem only seems to affect firefox.  However it could be a race condition somehow, not necessarily a bug in firefox.
(Reporter)

Comment 1

3 years ago
P.S. I have also reported it to curl and they are looking at it, so check there before looking into it here: https://github.com/cujojs/curl/issues/289
Component: Untriaged → Tabbed Browser
Product: Core → Firefox
Hi John,

Can you see if this is reproducible in the newest version of Firefox? Thanks.
Flags: needinfo?(john.duffell)
OS: Unspecified → Mac OS X
(Reporter)

Comment 3

2 years ago
Hi Grover thanks for getting back to me, after reporting it here and to curl loader, we eventually discovered it was some of our code falling over (due to us trying to access the dom before it was ready) and curl wasn't reporting the error anywhere.  So feel free to close this one down.  John
Flags: needinfo?(john.duffell)
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.