Closed Bug 11783 Opened 21 years ago Closed 17 years ago

Press return after password entry should login

Categories

(Bugzilla :: User Interface, enhancement, P3)

Other
Other
enhancement

Tracking

()

VERIFIED WONTFIX

People

(Reporter: hangas, Assigned: myk)

Details

(Whiteboard: Future-Target)

Attachments

(1 file)

The bugzilla login page does not do anything when return is pressed for the
password.  It would be great if it activated the login button rather than forcing
us to use the mouse to login.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → INVALID
As far as I know, this is entirely up to the browser.  There is nothing that a
CGI script can do to fix this.

If I'm wrong, please REOPEN the bug and tell me how I should make it work.

If you're really complaining that Mozilla the browser isn't doing the right
thing, then REOPEN this bug and change the Product to be "Browser".
I know it can be done but I cannot help write it.  I am using Mac Netscape 4.6
and have verified that the same problem exists on Windows Netscape 4.7.  It
should be possible to watch for a return from the password field and trigger the
same code that is called when the Login button is pressed.
Reopening to see if Tara has any ideas.  Maybe this could be done using JS where
present.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Over to Tara ...
Assignee: terry → tara
Status: REOPENED → NEW
QA Contact: matty
I've looked into this a bit...  It seems that on Netscape (any version) and IE 
3, if there is a form with more than one text element, then hitting return will 
not submit the form.  If there is only one text element, then hitting return 
will submit it.  In IE 4 and later, hitting return from any text element will 
submit that form, even if there is more than one text element.

This archived thread on lists.w3.org discusses this issue:
http://lists.w3.org/Archives/Public/w3c-wai-ig/1998AprJun/0368.html

The web page refered to in the first message there contains a bit more 
information.  Apparently, the HTML 2.0 spec did specify this behavior for forms, 
but later versions removed that specification, leaving it browser-dependent on 
whether or not to submit when return is pressed in a text input.

Since it's browser-specific, there's nothing we can do purely in HTML to address 
this problem.  If it's really a pressing issue, maybe there's a way to do it in 
JavaScript?
Well, I had a little more time on my hands than I expected, so I looked into it 
a little more.  It is (almost) possible with JavaScript.  Since IE does this 
already, I only needed to handle Netscape.  I was able to use an onKeyPress 
event to trigger the submission on pressing Enter.

However (this is the almost part), this event is only supported in Netscape 4.x, 
and it doesn't seem to be supported in the Linux version, so this is an 
extremely shaky solution at best.

Furthermore, my knowledge of JavaScript is slightly lacking, so I'm not sure how 
to cancel the keypress once I register it and see that it's Return, so it still 
beeps at you on pressing Return, but then submits.

I'm attaching a patch with my changes for reference, but this isn't quite ready 
for prime time yet.  I'm not entirely convinced that it's worth the effort, but 
it was interesting, so I've done what I've done so far.  Anyone else want to 
finish the job, or else tell me to stop wasting my time?  :-)
Heh I was about to tell you your patch didn't work on Linux until I noticed the
bit that said you were already aware of this fact.  I'm not thrilled with the
idea of JS mostly out of principle, but I'll toss this at some people and see if
they have any ideas.  If not, I'll reclose it out.
Status: NEW → ASSIGNED
I'm not particularly enamored of unnecessary JavaScript either...  I mostly did 
this just because it seemed like it would be interesting and fun to do, but I'm 
still unconvinced that it's worth actually putting in.  It seems like much 
bother to fix a problem that only some people consider a problem, and with a fix 
that won't work for everyone anyway...  We may want to just let this one remain 
as is...
Clearing platform:Mac from a Webtools bug
OS: Mac System 8.6 → other
Hardware: Macintosh → Other
I reccomend WONTFIX on this bug as it dives into browser quirks that are really
beyond the scope of what bugzilla should be expected to do.
I agree.  This is a browser-dependent problem.  If you don't like the way your 

browser handles forms, complain to the authors of the browser or get a different 

browser.  



Matty: your call, since you reopened it.

There's nothing wrong with handling browser quirks.  I seem to remember we've
had to do it before.  The question is how much effort is involved.  I would not
agree with working on a complex solution.

There's no guarantee we'll find a simple solution, but I don't see that we need
to close it out just because we don't have one yet either.
Whiteboard: Future-Target
moving to real milestones...
Target Milestone: --- → Future
Severity: normal → enhancement
Mozilla's behaviour may have been adapted to IE's, see bug 22526, patch 5:
"Enter submits anywhere, no pref.", fixed on 08/16/01. (Though I haven't
verified yet that it solved this bug for the Mozilla browser.)

-> Bugzilla product, User Interface component, reassigning.

 
Assignee: tara → myk
Status: ASSIGNED → NEW
Component: Bugzilla → User Interface
Product: Webtools → Bugzilla
Version: other → unspecified
Attachment #11306 - Flags: review?
The User Interface component now belongs to Gerv.  Reassigning all UNCONFIRMED
and NEW (but not ASSIGNED) bugs currently owned by Myk (the previous component
owner) to Gerv.
Assignee: myk → gerv
Reassigning back to Myk.  That stuff about Gerv taking over the User Interface
component turned out to be short-lived.  Please pardon our confusion, and I'm
very sorry about the spam.
Assignee: gerv → myk
This isn't worth worrying about.  It's a minor issue about a bug on an archaic
browser.  The only identified solutions are problematic, and nothing has
happened to this bug in years (except for Brant signing himself up to review the
patch, but I think he's doing that for pending patches in general).
Status: NEW → RESOLVED
Closed: 21 years ago17 years ago
Resolution: --- → WONTFIX
Target Milestone: Future → ---
I still agree with what I said in comment 11.

VERIFIED WONTFIX
Status: RESOLVED → VERIFIED
Comment on attachment 11306 [details] [diff] [review]
Patch to CGI.pl to allow submission of login info by pressing Return

The patch monster from summer 2000 strikes back... With the rot one would
expect.
Attachment #11306 - Flags: review? → review-
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.