overflow DIV property causes table mis-alignment

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
17 years ago
5 years ago

People

(Reporter: uberl0rd, Assigned: attinasi)

Tracking

({testcase})

Trunk
mozilla1.1alpha
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Really wierd one this - only started happening in 0.9.7. Also happens in latest
nightly (2002-01-06).

Basically, whenever you use overflow (auto and scroll values tested) in a DIV
element then any tables inside this element cannot be horizontally centered
using <table align="center">. Instead they almost (sometimes it works) appear at
the leftmost side of the DIV. Refreshing the page as no effect, but resizing the
window fixes it. After resizing, clicking on a form submit button inside this
table causes the table to jump back to the left again.

Comment 1

17 years ago
Reporter, please attachment a sample test case of the problem described.
(Reporter)

Comment 2

17 years ago
Created attachment 63438 [details]
overflow: auto causes mis-alignment

This is basically the default test12.html that ships with Mozilla that I've
hacked to duplicate the bug. To repliate, simply open the page (you may need to
refresh after loading). The main and footer sections will appear in the top
left most corner of the DIV - this is the problem. Resize the Mozilla window
and they will magically jump to their correct positions

it appears to also affect any block element (ie DIV) positioned with CSS

HTH

Comment 3

17 years ago
Changing component to style system
Assignee: attinasi → dbaron
Component: Layout → Style System
QA Contact: petersen → ian
Changing component back to layout.  I think this is a duplicate, though.
Assignee: dbaron → attinasi
Component: Style System → Layout
QA Contact: ian → petersen
Oddly enough, in today's CVS, I only see the footer out of position.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Whiteboard: DUPEME

Updated

17 years ago
Target Milestone: --- → mozilla1.1

Comment 6

17 years ago
Is there any way we can move this down to an earlier milestone?  This is a
pretty nasty layout bug.
(Reporter)

Comment 7

17 years ago
I certainly hope so - my intranet that our company sells is a bit foobar'ed
because of this. It worked fine in 0.9.6, but I couldn't use that as anchor
points didn't work on pages ending with .php. Iratating, as 0.9.7 fixed the
anchors, but broke the layout.
(Reporter)

Comment 8

17 years ago
Looks like this has been fixed in the RC1 build :)
I'll verify on a few more sites if I get time tomorrow

Comment 9

16 years ago
wfm winnt 2002112512 + reporters comment
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.