Closed Bug 1178365 Opened 5 years ago Closed 4 years ago

Can't exit fullscreen videos

Categories

(Firefox for Android :: General, defect)

41 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 42
Tracking Status
firefox41 --- fixed
firefox42 --- verified
fennec 41+ ---

People

(Reporter: snorp, Assigned: snorp)

References

Details

Attachments

(1 file, 1 obsolete file)

I noticed this last week, but couldn't file a bug. For whatever reason, it's impossible to exit fullscreen once you enter it when playing a video.
Kevin, can we get a regression range here?
Flags: needinfo?(kbrosnan)
Duplicate of this bug: 1176680
Version: Firefox 34 → Firefox 41
Flags: needinfo?(kbrosnan)
The inbound range I got is: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e423430262c8&tochange=59d11e593eca

It does not include bug 1105939, but I also don't see anything else obvious in there.
I just realized I recently reviewed a patch for bug 1161802, perhaps I messed that up? Or maybe there was a corresponding Android change needed for bug 1105939 that didn't happen.
I re-ran bisect and got a different Nightly range: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5787d784485e&tochange=bfd82015df48

Bug 1161802 is in that range, so that does seem likely.
We were missing this new widget listener callback, so the fullscreen change never completed.
tracking-fennec: ? → 41+
Assignee: nobody → snorp
Duplicate of this bug: 1178084
So on Android, we do not have sizemode, and the GeckoAppShell::SetFullScreen will synchronously change the size of the viewport, right? FullscreenChanged callback is supposed to be called after size change.
Flags: needinfo?(snorp)
(In reply to Xidorn Quan [:xidorn] (UTC+12) from comment #10)
> So on Android, we do not have sizemode, and the GeckoAppShell::SetFullScreen
> will synchronously change the size of the viewport, right? FullscreenChanged
> callback is supposed to be called after size change.

It's not synchronous, no. What badness will happen if the size changes later? I can work on a patch to wait on that before calling the callback.
Flags: needinfo?(snorp)
I'm trying to ensure the viewport size to be stable after that callback, so that content can rely on the window size when they get fullscreenchange event. It would also make our fullscreen tests more reliable, though they are currently not enabled on Android.
Attachment #8628892 - Flags: review?(blassey.bugs) → review+
Now we wait for an actual size change before notifying the widget listener
Attachment #8628892 - Attachment is obsolete: true
Attachment #8629977 - Flags: review?(quanxunzhen)
Attachment #8629977 - Flags: review?(blassey.bugs)
Attachment #8629977 - Flags: review?(blassey.bugs) → review+
Comment on attachment 8629977 [details] [diff] [review]
Fix DOM fullscreen support on Android

Review of attachment 8629977 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, thanks.
Attachment #8629977 - Flags: review?(quanxunzhen) → review+
https://hg.mozilla.org/mozilla-central/rev/f4ac17101a35
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Comment on attachment 8629977 [details] [diff] [review]
Fix DOM fullscreen support on Android

Approval Request Comment
[Feature/regressing bug #]: bug 1161802
[User impact if declined]: Unable to enter/exit fullscreen mode (incl. video)
[Describe test coverage new/current, TreeHerder]: Nightly
[Risks and why]: low, simply adjusts to widget changes made in other platforms
[String/UUID change made/needed]: none
Attachment #8629977 - Flags: approval-mozilla-aurora?
Comment on attachment 8629977 [details] [diff] [review]
Fix DOM fullscreen support on Android

Fix was verified on nightly. Let's land it on mozilla-aurora branch.
Attachment #8629977 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 1183590
Pressing "Back" after entering full screen for http://people.mozilla.com/~nhirata/html_tp/elephants-dream.webm video, will display correctly the page, so:
Verified as fixed using:
Device: Nexus 4 (Android 5.1)
Build: Firefox for Android 42.0a1 (2015-07-19)
The bug is still reproducible in build 42.0a2 (2015-08-10) using Asus Transformer Pad (Android 4.2.1).
You need to log in before you can comment on or make changes to this bug.