XBL inherits does not work with an explicit namespace

VERIFIED WORKSFORME

Status

()

Core
XUL
--
minor
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Miles Elam, Assigned: David Hyatt)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

17 years ago
Even if the "xbl" namespace is defined, "xbl:inherits" does not work in binding
content -- only "inherits" without any prefix works.  This is contrary to what
is expected when mixing different markup syntaxes such as XUL and XBL in a
single file.
(Reporter)

Comment 1

17 years ago
Created attachment 63668 [details]
XUL testcase source

Base XUL document with direct XBL linkage in "style" attribute to avoid the
extra CSS file and simplify the test case.  XBL follows...
(Reporter)

Comment 2

17 years ago
Created attachment 63669 [details]
XBL bindings for previous XUL attachment

XBL bindings for previous XUL attachment.  When the "xbl:" prefix is removed
from the XUL buttons, the attribute works as normal.  With the namespace prefix
(which should be valid in this case due to inherit's association with XBL and
not XUL or the default namespace, the testcase does not inherit the attributes.
(Reporter)

Comment 3

17 years ago
Created attachment 63670 [details]
The *REAL* XUL testcase source

The *REAL* XUL testcase source.  Sorry about that David...  Choose the wrong
file to attach earlier by accident.  Unfortunately I don't have the right to
obsolete attachments(?) even though I opened this bug and attached the
offending file.  Should I open a new bug for bugzilla?
(Reporter)

Updated

17 years ago
Keywords: testcase

Comment 4

16 years ago
Jonas, seeing as you implemented this, I thought you might like to look into it.
does this still not work? the support for xbl:inherits (as opposed to just 
inherits) was checked in 2002-02-19
Created attachment 81824 [details]
XUL testcase that points at the XBL
Attachment #63668 - Attachment is obsolete: true
Attachment #63670 - Attachment is obsolete: true
Marking worksforme, since it does, with a current linux build.  :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 8

16 years ago
Yeah, and lots of things would be broken all over if this didn't work, since we
use it everywhere in our codebase.  Verified.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.