bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Make Homescreen to behave more like a normal app: swipe gestures from left/right should reveal other running apps

RESOLVED DUPLICATE of bug 1045790

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED DUPLICATE of bug 1045790
3 years ago
3 years ago

People

(Reporter: smaug, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Getting from Homescreen to running apps is totally different UX than getting from
some other app to running apps - and I don't really see any reason for this inconsistency.
Thanks for filing this. We do have bug 1045790 which would place the homescreen at the right of the list of open windows in the task manager. I think we agree - this was a feature in the "Haida" UX spec and its just waiting in line for implementation. The simplest way to implement would be to involve removing the special-cases in StackManager/EdgeSwipeDetector and that would also have the effect that the homescreen would appear at far right of the edge-swipe list. I'm going to dupe to 1045790, please re-open or comment there if you have further thoughts.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Component: Gaia::Homescreen → Gaia::System::Window Mgmt
Resolution: --- → DUPLICATE
Duplicate of bug: 1045790
You need to log in before you can comment on or make changes to this bug.