Closed Bug 1178459 Opened 4 years ago Closed 4 years ago

Run password autofill code when a password field is added to a document outside of a <form> (Port relevant parts of Bug 1168707)

Categories

(SeaMonkey :: Passwords & Permissions, defect)

defect
Not set

Tracking

(seamonkey2.38 fixed, seamonkey2.39 fixed)

RESOLVED FIXED
seamonkey2.39
Tracking Status
seamonkey2.38 --- fixed
seamonkey2.39 --- fixed

People

(Reporter: philip.chee, Assigned: philip.chee)

References

Details

Attachments

(1 file)

(In Bug 1168707 comment #0)
> Autofill should occur and autocomplete should be setup when the notification
> from bug 1132211 about a new password field is received.
Summary: Run password autofill code when a password field is added to a document outside of a <form> → Run password autofill code when a password field is added to a document outside of a <form> (Port relevant parts of Bug 1168707)
Attachment #8630102 - Flags: review?(neil)
Attachment #8630102 - Flags: review?(neil) → review+
http://hg.mozilla.org/comm-central/rev/c28cb7d2b99d
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.39
Comment on attachment 8630102 [details] [diff] [review]
Patch v1.0 simple copy&paste

[Approval Request Comment]
Regression caused by (bug #): Bug 1168707 - When a password field is added to a document (possibly outside of a <form>) the autofill code should run

User impact if declined: When a password field is added to a document (possibly outside of a <form>) the autofill code does not run.
Testing completed (on m-c, etc.): Firefox 41 SeaMonkey 2.39a
Risk to taking this patch (and alternatives if risky): none, enhancement only.
String changes made by this patch: none.
Attachment #8630102 - Flags: approval-comm-aurora?
Attachment #8630102 - Flags: approval-comm-aurora? → approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.