Closed Bug 117846 Opened 23 years ago Closed 20 years ago

Edit mailing list with card DisplayName containing commas removes email address from card, removes other cards from list

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect)

All
Windows ME
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 222711
mozilla1.8beta1

People

(Reporter: nbaca, Assigned: sspitzer)

References

Details

(Whiteboard: nab-mlist)

Overview: You can get into a state where the cards in the mailing list do not
match the cards that appear in the Results Pane. 

The steps to reproduce this are currently unknown but we wanted to log this bug
so that scenarios may be added to this bug.
Whiteboard: nab-mlist
Nominating.  If you could come up with some steps for this, that would be
helpful.    We don't want the user to be in a state where they think they are
sending mail to a different set of people than they really are.
Status: NEW → ASSIGNED
Keywords: nsbeta1
Keywords: nsbeta1nsbeta1-
Blocks: 136757
This gets me all the time. I cannot creater a list with even 8 names in it.
What happens is that after a few names are entered, typing new names into the
list activates the name finder, which pops up correctly. However, whet gets
stored in the address list is what you typed in, and Not the person's e-mail.

You then go to try and use the list, and it fails because the users are unknown.

You open the list, and you get several lines with just last names in them.
It takes 3 or 4 trys at deleting the names, adding new ones, closing the list,
and reopening it again before it can get right.

So, basically it is still impossible to make a mailing list, and has been
impossible ever since the list was made to be modal. The original method of
dragging names from the main address book onto the list worked just fine. Now
there is no reliable way to make a list. I am on build 2003060704 in WinXP.

This method of list creation does not work. You MUST see both the list and the
address book at the same time to tell 1) what is in the list and 2) who is in
the address book.
Severity: normal → critical
I repeatedly had the following problem.
After importing my outlook address book, I wanted to create a mailing list:
While creating it, everything seemed ok, but then only the screen-name remained
and the mail sent came back to me because of the uncomplete address. 
Yup. This happens all the time. The entry just has the names and not the address.
The address book is quite useless for mailing lists, and no action is being
taken on these problems.

It is critical too.
This happens every time with the following scenario:

1) Make a list with more than 5 entries by typing the names and getting
autocopmpletion. I did 8 names.

2) Save the list.

3) Close the address book.

4) Open the addressbook and double click on the list. Some of the names will be
there without an e-mail address. 

It is IMPOSSIBLE to get them to stay in the list correctly. You can try fixing
the list and repeating steps 2-4 until you are blue in ght face and some of the
names will always keep dropping their addresses.

I do not think 1.5 should be released until this is fixed IMHO. I have been
complaining of this problem ever since the list was made to be modal, which is
when everything broke. The user interface (even if it worked) is truly awful
because the user cannot simultaneously see the main mailing list (to select the
names from) and the names in the mailing list.
I am able to recreate this bug in WinXP Pro with Mozilla 1.6b and Mac OSX 10.3.2 with Mozilla 1.6b, though using slightly more specific directions than provided by James in comment #5.

This bug affects lists that contain contacts whose display name contains a comma. Since many display names are in the form "firstname, lastname" this is not unlikely to happen.

Steps to reproduce:

1. Verify that you have at least one address book card that has at least:
a) an e-mail address
b) a display name which contains a comma
If you don't have such an address book card, make one.

2. Create a new mailing list

3. Add to this list the contact whose card you have verified has both an e-mail  address and a display name containing a comma. Note that the listing appears with the display name enclosed in quotes and the e-mail address enclosed in angle brackets. Click "OK" to save and close the mailing list.

4. Locate the mailing list you created in step 2, and double click to open it. Note that the display name is no longer enclosed in quotes. The e-mail address still appears in angle brackets. Click "OK" to save and close the mailing list.

5. Re-open the same mailing list. Observe that the listing which previously contained both a display name containing a comma and an e-mail address now contains only the portion of the display name which was located to the left of the comma.

The expected behavior would be that mailing list contents would remain unchanged regardless of the presence of a comma in the display name.

Notes:
If you had created a mailing list containing more than one contact, all contacts listed after the contact whose display name contained a comma would be missing from the mailing list when you re-opened it in step 5. Contacts listed before the the first instance of a contact with a comma in the display name would remain intact.

I'm no programmer, but I believe that it is in step 3 where the display name appears without quotes that Mozilla is recognizing the portions of the display name separated by the comma as two separate entries.

I am also of the belief that this is a critical problem, and I'd love to see it get resolved. I'd do it myself if I knew how.
I would also like to apologize for whatever made the lines of my comment fail to wrap.
Finally someone has at least recognized that this is a CRITICAL bug. Mailing
lists are totally useless as they stand.
Flags: blocking1.6+
James,
The testing I did indicated that mailing lists DO work properly as long as one has no commas in the display names of contacts. If you take a few minutes (or hours, depending on the size of your address book) to edit the display names of all your contacts (or just those you use in mailing lists) you can prevent this problem from happening.
I believe this problem is significant, but the comma-removal workaround does seem to be effective. I would NOT call that a resolution, though.
Well, finding people by their first names is a true pain. All of my dosplay
names are last name, first name.
And I have a HUGE list the gets bigger all the time because Mozilla will not let
me merge lists properly.
Well, 1.6 shipped, so I don't think it's blocking
Flags: blocking1.6+ → blocking1.6-
Sorry, shouldn't have removed the flag, not my role.  Restoring so someone else
can remove it.
Flags: blocking1.6- → blocking1.6+
Removing flag. 
James Rome, please don't set the blocking+ flag. This is reserved for mozilla
drivers. See
http://www.mozilla.org/quality/help/bugzilla-privilege-guide.html#flags for more
information.
Flags: blocking1.6+
I apologize for the flasg, but I am getting very frustrated about address lists.
This bug has been there for over a year now -- ever since the address list box
was made non-modal. Address lists in general are badly flawed because it is now
impossible to see the list and the list of all your names at the same time so
that you can properly make the list.
updating summary to better match reproducibility steps in comment 6.
Old: Cards in a Mailing List do not always match the cards in the Results Pane

possible dupes: 229791, 232315, 216114.  All awaiting reporter comments.
Summary: Cards in a Mailing List do not always match the cards in the Results Pane → Edit mailing list with card DisplayName containing commas removes email address from card, removes other cards from list
Another month gone by and still no fix. Removing the comma from the names is NOT
a fix. I want my addresses sorted by last name in the display name, and I have
several thousand entries in my address book. Why isn't anyone fixing this?
two more months and NO fix. Can someone please fix this bug?
Still NO action. Seth, why isn't this getting fixed? 
*** Bug 232315 has been marked as a duplicate of this bug. ***
*** Bug 229791 has been marked as a duplicate of this bug. ***
*** Bug 237441 has been marked as a duplicate of this bug. ***
Just got another call from a user who encountered this bug. Noticed that nobody
has said much about it in a month. Just voted for this bug, hoping that helps.
Really looking forward to this bug's resolution.
on it.
Target Milestone: --- → mozilla1.8beta
with mozilla 1.7 branch build I haven't reproduced this yet:  the quotes are
preserved.
mozilla trunk debug also seems to work.

james, do you still see this?

I looked over the checkins from 4/01 to now to mozilla/mailnews/addrbook, and I
don't see anything.  (there was one thing from neil, but that was for email
collection).

neil, mscott or david:  did one of you fix this as part of another bug?

*** This bug has been marked as a duplicate of 222711 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
thanks neil, and thanks for fixing this!
No! This is not fixed properly. Now (Linux build 2004051305) when I try to add a
name to a mailing list by double-clicking the list name, as soon as I click on
the blank line, Mozilla crashes! I will download today's build and recheck.
The 5/24 Linux build does not crash :-)

Now, quotes seem to get put around my last_name, first_name entries. I guess
this is OK.

I still HATE the way mailing lists work though. It is impossible to drag names
from the main list onto the mailing list the way one could before the dialog
became modal. One has to guess at the names one wants to put on the list without
being able to scroll down the main  address book to jog one's memory.

But I guess this is fixed.
One workaround is to create an empty list and then drag the addresses from the
address book in the right pane to the address list in the left pane.
The problem with that workaround is that you cannot see who is on the list. The
user interface was really good, and now is really bad. Why can't the lists be
non-modal again with drag and drop between the main book and the list?
> But I guess this is fixed.

verifying, based on your comment.

> Why can't the lists be non-modal again with drag and drop between the main
book and the list?

there's is a bug that covers the issues, I'm sure you can find it if you query
the verified / fixed bugs.

> I still HATE the way mailing lists work though

yes, there are problems.  (see bug #136757).  
but improvements are being made, thanks to people like neil.

please continue to help by triaging / confirming / marking duplicates and
getting test cases where we don't have any
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.