[FTU] The About Firefox OS page no longer has "Yes! Send data" option checked by default

VERIFIED FIXED

Status

Firefox OS
Gaia::First Time Experience
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: piwei, Assigned: kgrandon)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing][spark])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Description:
According to bug 1134445, this option should be checked by default.

STR:
1) Flash to latest central build
2) During FTU, progress to the About Firefox OS page, and observe the checkbox for "Yes! Send data" option

Expected: The Yes! Send data option should be checked by default

Actual: It is not checked by default

Device: Flame (full flashed, 319MB, KK)
BuildID: 20150629010206
Gaia: 8a1e4ae522c121c5cacd39b20a5386ec9055db82
Gecko: eaf4f9b45117
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 41.0a1 (2.5 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Note:
Possibly caused by bug 1176905
(Reporter)

Comment 1

3 years ago
Aries is affected as well.
Device: Aries
BuildID: 20150629211839
Gaia: 27fe0f4261e3685187769411f2f74cff19287b19
Gecko: c26dbd63604d
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5 Master) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

--------------

Flame 2.2 is unaffected (PVT website doesn't have today's 2.2 nightly)
Device: Flame 2.2
BuildID: 20150626162505
Gaia: 0179935627012dfde3ca036c9a71035be463b7ad
Gecko: 330f52ef6a2d
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [3.0-Daily-Testing][spark]
[Blocking Requested - why for this release]:

Smoketest blocker. Let's get a regression window on this.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qaurgent, regressionwindow-wanted, smoketest
(Reporter)

Updated

3 years ago
QA Contact: pcheng
(Reporter)

Updated

3 years ago
Whiteboard: [3.0-Daily-Testing][spark] → [2.5-Daily-Testing][spark]
(Reporter)

Comment 3

3 years ago
b2g-inbound regression window:

Last Working
Device: Flame
BuildID: 20150624175256
Gaia: 038e917076271d304b906a41b4de670e505c67ae
Gecko: d0822eec251e
Version: 41.0a1 (2.5 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Broken
Device: Flame
BuildID: 20150624180855
Gaia: a1b180b1964dfd939798d7e076435f421fca983f
Gecko: 8c8f3820dec3
Version: 41.0a1 (2.5 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Last Working Gaia First Broken Gecko - no repro
Gaia: 038e917076271d304b906a41b4de670e505c67ae
Gecko: 8c8f3820dec3

Last Working Gecko First Broken Gaia - repro
Gaia: a1b180b1964dfd939798d7e076435f421fca983f
Gecko: d0822eec251e

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/038e917076271d304b906a41b4de670e505c67ae...a1b180b1964dfd939798d7e076435f421fca983f

Caused by changes made in Bug 1176905.
Blocks: 1176905
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qaurgent, regressionwindow-wanted
Kevin, can you take look at this please? This looks to have been caused by the landing for bug 1176905.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(kgrandon)
(Assignee)

Comment 5

3 years ago
I tested this on the latest master and it appears to work for me. I checked and it seems that bug 1177432 may have fixed this.

Can you please test again on the next nightly build? Not sure how to ask for this, maybe setting [QAnalyst-Triage?]?
Assignee: nobody → kgrandon
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Depends on: 1177432
Flags: needinfo?(kgrandon)
Resolution: --- → FIXED
for verifying a smoketest blocker it's keywords (qawanted, verifyme, qaurgent)

Verifyme puts it in the large verification query
qawanted puts it in the to do list for qawanted team
qaurgent puts it in the Highest Priority list (reserved for smoke, sanity, and severe issues)
QA Whiteboard: [QAnalyst-Triage?]
Keywords: qaurgent, qawanted, verifyme
Created attachment 8628051 [details]
Verify1_Flame master_Pass.3gp

According to the STR in comment 0, this issue is verify pass on latest Flame master build.

Actual result: The Yes! Send data option is checked by default.
See attachment:Verify1_Flame master_Pass.3gp.
Reproducing rate:0/5

Device: Flame master build (Pass)
Build ID               20150630160220
Gaia Revision          5997b406e77ea726fbd9047057a1c3504f6cd6d4
Gaia Date              2015-06-30 01:48:01
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/291614a686f1
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150630.193722
Firmware Date          Tue Jun 30 19:37:34 EDT 2015
Bootloader             L1TC000118D0


Leaving “verifyme”, "qaurgent" and "qawanted" for Aries verification.
QA Whiteboard: [MGSEI-Triage+]
This issue is resolved fixed on the latest Flame 2.5 build.
The "Yes! Send data" option is checked by default.

Environmental Variables:
Device: Flame 2.5
Build ID: 20150701010205
Gaia: 90ed5ebde89b6fc095524e47c59d5b8d192d3ff2
Gecko: 079b6f1ae1c3
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+][QAnalyst-Triage?]
status-b2g-master: affected → verified
Flags: needinfo?(ktucker)
Keywords: qaurgent, qawanted, verifyme
QA Whiteboard: [MGSEI-Triage+][QAnalyst-Triage?] → [MGSEI-Triage+][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: 2.5? → 2.5+
You need to log in before you can comment on or make changes to this bug.