the phone doesn't vibrate when I press a number in the Calculator app

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: isandu, Unassigned)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bzlite][triagr] [foxfoodUX] 2.6UXnom)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

The phone should provide haptic feedback when I press a number in the Calculator app.
Keywords: foxfood
Keywords: dogfood
Triagr automatic comment: didn't know what to do when triaging.
Flags: needinfo?(fxos.triage)
Whiteboard: [bzlite] → [bzlite][triagr]

Updated

4 years ago
Flags: needinfo?(fxos.triage.feature)
Flags: needinfo?(firefoxos-ux-bugzilla)
Whiteboard: [bzlite][triagr] → [bzlite][triagr] [foxfoodUX]
Keyboard should consistently providing haptic feedback - it seems like Calculator is a one off.

NI Harly as FYI.

Thanks for pinging the UX team!
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(hhsu)

Comment 3

3 years ago
Yes, I agree with both Irina and Tiff that we should probably add haptic feedback to calculator.
Flags: needinfo?(hhsu)
Whiteboard: [bzlite][triagr] [foxfoodUX] → [bzlite][triagr] [foxfoodUX] 2.6UXnom

Comment 4

3 years ago
Created attachment 8692915 [details] [diff] [review]
Bug 1178579 - Adding haptic feedback for key press.patch

Fabrice, I've choosen you for review since you are the only suggested reviewer for this component. However, I'm not sure whether you are the right person for calculator related bugs, so please feel free to reassign it to more suitable person.

The patch is very simple, but the problem is that calculator is not a part of gaia repository and it is distributed as hosted app. The source code is stored in a separate repository, so I've also created a PR there: https://github.com/mozilla/calculator/pull/95
Attachment #8692915 - Flags: review?(fabrice)
Comment on attachment 8692915 [details] [diff] [review]
Bug 1178579 - Adding haptic feedback for key press.patch

Review of attachment 8692915 [details] [diff] [review]:
-----------------------------------------------------------------

r=me 
Let me know if you need help to merge the PR.
Attachment #8692915 - Flags: review?(fabrice) → review+

Comment 6

3 years ago
Fabrice, thanks for the review! I would appreciate your help with merging this. I requested Nick Desaulniers to merge this PR to calculator repo (https://github.com/mozilla/calculator/pull/95), but I'm not sure how long it will take since last activity for this repo was more than a year ago. 

I'm also not sure whether I need to manually update application.zip in hosted_apps folder in gaia repo here https://github.com/mozilla-b2g/gaia/tree/master/hosted_apps/calculator or it is automatically taken from calculator repo by some script. So, if you have any idea how to handle it please advise the right way.
Flags: needinfo?(fabrice)
It looks like Nick is looking at your PR, so I'll let him merge.
https://github.com/mozilla-b2g/gaia/tree/master/hosted_apps/calculator will have to be updated once the calculator app is updated in the marketplace.
Flags: needinfo?(fabrice)
version 2.0.3 is in the review queue.  Thanks all!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(fxos.triage)
Flags: needinfo?(fxos.triage.feature)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.