crash in libGLESv2_POWERVR_SGX544_115.so@0x6c14

REOPENED
Unassigned

Status

()

Core
Canvas: WebGL
P3
critical
REOPENED
3 years ago
4 months ago

People

(Reporter: Jukka Jylänki, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted], crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-fb81d782-6ea5-422b-9d69-6b72d2150629.
=============================================================

STR: 1. Visit https://www.khronos.org/registry/webgl/sdk/tests/conformance/extensions/oes-texture-float-with-canvas.html?webglVersion=1

Tested to crash on

SAMSUNG-GT
----------

Samsung GT-I9500 (April 2013)
1080x1920 pixels display
Chipset: Samsung Exynos 5 Octa 5410
CPU: Quad-core 1.6 GHz Cortex-A15 & quad-core 1.2 GHz Cortex-A7
2GB of RAM
GPU: Imagination PowerVR SGX544MP3
	- OpenGL ES 2.0
Android 5.0.1
 - This is an important device because it is part of the Firefox Content Performance Program, https://wiki.mozilla.org/Firefox/Content_Performance_Program
Firefox Nightly 41.0a1 (2015-06-29)
(Reporter)

Comment 1

3 years ago
Did not occur on any of the following: SPARK, GIADA, MACBOOK_AIR_OSX, MACBOOK_AIR_WIN, MACBOOK_PRO_OSX, MACBOOK_PRO_WIN, MACMINI, MACPRO, NEXUS-4, NEXUS-5, NEXUS-10, SURFACE, WINDBOX, HASWELL, HPOMEN (see https://bugzilla.mozilla.org/show_bug.cgi?id=1178601 for hardware configuration details of these systems)
(Reporter)

Comment 2

3 years ago
Similary, SAMSUNG-GT crashes when running the page https://www.khronos.org/registry/webgl/sdk/tests/conformance/extensions/oes-texture-half-float-with-canvas.html?webglVersion=1 , giving the following crash stack: https://crash-stats.mozilla.com/report/index/55a1d4a7-9fe4-4a68-a931-3d9cf2150629 , so the root causes for both failures might be the same.
(Reporter)

Comment 3

3 years ago
Did not crash on any of the following: SPARK, GIADA, MACBOOK_AIR_OSX, MACBOOK_AIR_WIN, MACBOOK_PRO_OSX, MACBOOK_PRO_WIN, MACMINI, MACPRO, NEXUS-4, NEXUS-5, NEXUS-10, SURFACE, WINDBOX, HASWELL, HPOMEN (see https://bugzilla.mozilla.org/show_bug.cgi?id=1178601 for hardware configuration details of these systems)
Whiteboard: [gfx-noted]
Mass resolving WFM: signature(s) hasn't(/haven't) reported in past 28 days.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

2 years ago
Reopening, as the above is not a valid grounds for closing this bug.

This bug refers to a crash in the official WebGL conformance suite, which we test the official WebGL implementation functionality against. Closing bugs on statistical basis loses valuable information for developers. Closing a bug as WORKSFORME means you have tried the bug on the target hardware and OS on the latest browser, and can verify that the steps no longer produce the bug. We should not close bugs on statistical grounds unless they were opened on statistical grounds in the first place, or if they don't have clear steps to repro. This bug has a clear STR attached to it. Edwin, could you please revisit and reopen any bugs you have closed which either refer to an official conformance suite and/or have a clear steps to repro?
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Jukka, please retest this to see if it's still valid.
Flags: needinfo?(jujjyl)
(Reporter)

Comment 7

2 years ago
Retested this with the hardware from comment 0 on latest FF Nightly, and the crash still occurs.

https://crash-stats.mozilla.com/report/index/e37123f8-1cd2-4be2-8526-0e7af2160720
Flags: needinfo?(jujjyl)
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.