Screen shots are not appearing in Gallery app

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Gallery
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Irina Sandu, Unassigned)

Tracking

({foxfood})

unspecified
foxfood

Firefox Tracking Flags

(blocking-b2g:2.5+)

Details

(Whiteboard: [bzlite])

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

When I add an attachment from the Gallery to an email I see 5 pictures in my Gallery. But when I go to the Gallery app from the Home screen I only see 2 pictures. The missing 3 pictures are screenshots that I took by pressing the volume keys.
Keywords: foxfood
Keywords: dogfood
blocking-b2g: --- → 2.5+
QA Whiteboard: [foxfood-triage]
Component: Gaia::Feedback → Gaia::Gallery
Hi Irina

I failed to replicate the issue on my Sony Z3C with Build Id - 20150714105722. I am seeing the screen shot images taken using volume key, in both instances of gallery (invoked via home screen and from email app to attach an image).

It will help if you can provide detail STR and if possible logs. Thanks!
Flags: needinfo?(isandu)
Hi No-Jun
This 2.5+ is not replicable for me and need your help to test and update the bug with your findings on latest build. Thanks!
Flags: needinfo?(npark)
Peter, wasn't there a dogfood bug where not all pictures were visible in gallery app but shown in pick activity?

Actually, maybe I'm thinking of Bug 1164200 - adding qawanted to check on latest Aries dogfood build.
Flags: needinfo?(npark) → needinfo?(pbylenga)
Keywords: qawanted
I'm unable to reproduce that issue as I see my screenshots in the gallery app as well as pick activity.

Leaving qawanted to try, perhaps changing the default location for media?  If you set it to sdcard, but screenshots are always taken to internal?
Flags: needinfo?(pbylenga) → needinfo?(npark)
Summary: the Gallery is not the same when accessed through the app as when accessed through email app → Screen shots are not appearing in Gallery app

Comment 5

3 years ago
I was unable to reproduce this for the following Aries build:

Environmental Variables:
Device: Aries 2.5 Kk
BuildID: 20150727165113
Gaia: 302a448729ff2b336581cf94b66327ea836294c7
Gecko: d576f2cec511
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

I attempted this by saving 3 screenshots to Internal Drive, SD Card 1 and SD Card 2. All screenshots would appear in Gallery from Homescreen successfully. Leaving for additional QA to attempt.

Updated

3 years ago
QA Whiteboard: [foxfood-triage] → [QAnalyst-Triage?][foxfood-triage]
Flags: needinfo?(ktucker)

Comment 6

3 years ago
Based on comment 5, marking as worksforme. If this issue is still reproducible, please reopen.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
QA Whiteboard: [QAnalyst-Triage?][foxfood-triage] → [QAnalyst-Triage+][foxfood-triage]
Flags: needinfo?(ktucker)
Keywords: qawanted

Updated

3 years ago
Flags: needinfo?(npark)
Flags: needinfo?(isandu)
You need to log in before you can comment on or make changes to this bug.