Highlighted button text doesn't obey Windows high-contrast theme setting

RESOLVED DUPLICATE of bug 1178702

Status

RESOLVED DUPLICATE of bug 1178702
4 years ago
4 years ago

People

(Reporter: k_kolev1985, Unassigned)

Tracking

38 Branch
x86_64
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8627601 [details]
Screenshot_2015-06-30_12-24-55.png

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

1. Enable a high-contrast theme in Windows. To do so, do the following:
1.1. Go to the desktop.
1.2. Right-click on it and from the pop-up menu choose "Personalize".
1.3. From the list of themes, choose "High-Contrast Black", by single left-clicking on it.
2. Launch ThunderbirdI'm running the latest stable version - 38.0.1 on a Windows 8.1 64-bit machine.
3. Invoke a dialog box with some buttons in it. The one for Thunderbird's options will do just fine. I'm attaching a screenshot of it.
4. With the TAB key, move the system focus to each of the buttons.


Actual results:

The focused button gets highlighted, as it should. The text in it however in such a case remains white, making it very hard to see.


Expected results:

The text in the focused highlighted button should become black, as it is defined in the currently used Windows theme.

Updated

4 years ago
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86_64
This is a core issue and the bug opened for Firefox is enough.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1178702
You need to log in before you can comment on or make changes to this bug.