Event region on the compositor should be updated when apz-aware listeners are added or removed to the DOM

RESOLVED DUPLICATE of bug 1131188

Status

()

RESOLVED DUPLICATE of bug 1131188
4 years ago
3 years ago

People

(Reporter: kats, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

See bug 1177651 comment 6 for backstory. There is a test (test_moz_mouse_pixel_scroll_event.html) which fires a mouse wheel event and also does a prevent default on that event. The very first time this happens in the test the prevent default has no effect because APZ doesn't wait for the wheel event listener. This, in turn, happens because the listener is registered just prior to the wheel event dispatch and the event regions on the compositor side don't get updated in time (that only happens on a repaint). In this case it doesn't break the test, but it may cause intermittent failures in other tests - if we want this scenario to work properly, we should trigger some sort of flush when APZ-aware listeners are added to/removed from the DOM, to push the updated event regions over to the compositor.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1131188
You need to log in before you can comment on or make changes to this bug.