Closed Bug 1178785 Opened 4 years ago Closed 4 years ago

Mac nightly l10n repacks busted

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(firefox41 fixed, firefox42 fixed)

RESOLVED FIXED
Tracking Status
firefox41 --- fixed
firefox42 --- fixed

People

(Reporter: rail, Assigned: mshal)

References

Details

Attachments

(2 files, 1 obsolete file)

See https://treeherder.mozilla.org/logviewer.html#?job_id=927855&repo=mozilla-aurora


06:18:33 INFO - FirefoxDeveloperEdition.app/Contents/Resources/res/cursors/zoomOut@2x.png
06:18:33 INFO - FirefoxDeveloperEdition.app/Contents/Resources/webapprt/
06:18:33 INFO - FirefoxDeveloperEdition.app/Contents/Resources/webapprt/omni.ja
06:18:33 INFO - FirefoxDeveloperEdition.app/Contents/Resources/webapprt/webapprt.ini
06:18:33 INFO - FirefoxDeveloperEdition.app/Contents/_CodeSignature/
06:18:33 INFO - FirefoxDeveloperEdition.app/Contents/_CodeSignature/CodeResources
06:18:33 INFO - sent 324883183 bytes received 2648 bytes 13824928.98 bytes/sec
06:18:33 INFO - total size is 324834692 speedup is 1.00
06:18:33 INFO - "disk3" unmounted.
06:18:33 INFO - "disk3" ejected.
06:18:38 INFO - + rsync -a /builds/slave/m-aurora-m64-l10n-ntly-6-00000/build/mozilla-aurora/obj-l10n/dist/unpack.tmp/Nightly.app firefox
06:18:38 INFO - rsync: link_stat "/builds/slave/m-aurora-m64-l10n-ntly-6-00000/build/mozilla-aurora/obj-l10n/dist/unpack.tmp/Nightly.app" failed: No such file or directory (2)
06:18:38 INFO - rsync error: some files could not be transferred (code 23) at /SourceCache/rsync/rsync-42/rsync/main.c(992) [sender=2.6.9]
06:18:38 INFO - make: *** [/builds/slave/m-aurora-m64-l10n-ntly-6-00000/build/mozilla-aurora/obj-l10n/dist/l10n-stage/firefox/Nightly.app/Contents/Resources] Error 23
06:18:38 ERROR - Return code: 2
06:18:38 ERROR - 2 not in success codes: [0]
06:18:38 WARNING - setting return code to 2
06:18:38 FATAL - Halting on failure while running ['make', 'unpack']
06:18:38 FATAL - Running post_fatal callback...
06:18:38 FATAL - Exiting 2
program finished with exit code 2
elapsedTime=565.349307
I think browser/confvars.sh should have:

MOZ_BRANDING_DIRECTORY=browser/branding/aurora

instead of:

MOZ_BRANDING_DIRECTORY=browser/branding/unofficial

Does that sound right? I tested this locally, and it changes MOZ_APP_DISPLAYNAME from 'Nightly' to 'FirefoxDeveloperEdition', which is the variable used in the rsync command that is failing (the dmg file contains FirefoxDeveloperEdition.app, not Nightly.app).
Hmmm, I think in bug 1157289 we wanted to stop touching that... Maybe we should add "ac_add_options --with-branding=browser/branding/aurora" to http://hg.mozilla.org/releases/mozilla-aurora/file/f77a4ceb2389/browser/config/mozconfigs/macosx64/l10n-mozconfig and for other platforms as well?
I can confirm that using ac_add_options also works (locally by checking MOZ_APP_DISPLAYNAME in config.status), though the mozconfig used is macosx-universal/l10n-mozconfig. The macosx64/l10n-mozconfig file doesn't appear to be referenced anywhere.
Attached patch aurora-mac-l10n-branding (obsolete) — Splinter Review
I'm testing this on staging at the moment.
Assignee: nobody → mshal
Attachment #8627786 - Flags: review?(rail)
Comment on attachment 8627786 [details] [diff] [review]
aurora-mac-l10n-branding

Can you add this line to other platforms to be consistent?

I think we should also apply this to m-c as well.
Attachment #8627786 - Flags: review?(rail)
Attachment #8627786 - Attachment is obsolete: true
Attachment #8627889 - Flags: review?(rail)
Attachment #8627889 - Flags: review?(rail) → review+
Attachment #8627890 - Flags: review?(rail) → review+
Blocks: 1178507
Comment on attachment 8627889 [details] [diff] [review]
aurora-l10n-branding

Approval Request Comment
[Feature/regressing bug #]:
[User impact if declined]: OSX l10n busted
[Describe test coverage new/current, TreeHerder]: Tested OSX in a staging environment
[Risks and why]: 
[String/UUID change made/needed]:
Attachment #8627889 - Flags: approval-mozilla-aurora?
Blocks: 1177917
Summary: Mac nighlty l10n repacks busted → Mac nightly l10n repacks busted
https://hg.mozilla.org/mozilla-central/rev/44561e7653ed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Still need to land on m-a
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status flags track branch uplifts. Resolution tracks landing on m-c.
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Comment on attachment 8627889 [details] [diff] [review]
aurora-l10n-branding

Aurora+ Sorry that we missed this earlier.
Attachment #8627889 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
mshal just informed me I pushed the wrong patch - thanks!

backed out the previous one and pushed the correct one instead:
https://hg.mozilla.org/releases/mozilla-aurora/rev/ae18ebff50df
Got my aurora update today, marking fixed 41.
I wonder if this caused this report?
Fx 41.0a2 (2015-07-03) claims to be Nightly, should be DeveloperEdition
Bug 1180336

I saw this using Windows.

Screenshot 2015-07-03
https://bug1180336.bugzilla.mozilla.org/attachment.cgi?id=8629535

The Menus all have (had on 2015-07-04) "Nightly".
For example "Nightly Help", "Nightly Tour", "Nightly Health Report" etc.

See also other reports here:
http://forums.mozillazine.org/viewtopic.php?f=23&t=2945003

However, all seems to be 'back to normal' now.

See screenshot 2015-07-05
https://bug1180336.bugzilla.mozilla.org/attachment.cgi?id=8629664

Menus now say
"Firefox Help", "Firefox Tour", "Firefox Health Report" etc.

Is this expected?  I can't remember is they used to say
"Firefox" or "DeveloperEdition" e.g. "DeveloperEdition Tour".

DJ-Leith
Blocks: 1180336
I commented in bug 1180336 (and closed it). It was caused by this bug.
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.