test_sync_facebook_contacts.py: No longer testable; advising permafail

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: onelson, Assigned: martijn.martijn)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Description:
test_facebook_sync_contacts.py is no longer a viable test due to bug 1175455: the import facebook contacts button has been removed from settings. Following the meta bug 1173011 indicates to me that this feature may return with a new API, so advising that this case becomes a permafail while this is sorted out.

* http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/132/HTML_Report/
* http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc.bitbar/112/HTML_Report/


Repro Steps:
1) Update phone to 20150629134017
2) Open Contacts
3) Tap gear for settings

Actual/Expected:
No longer an option for importing contacts from facebook


Traceback (most recent call last):
File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_client-0.16-py2.7.egg/marionette/marionette_test.py", line 296, in run
testMethod()
File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/tests/functional/contacts/test_sync_facebook_contacts.py", line 33, in test_import_contacts_from_facebook
facebook = contacts_settings.tap_sync_friends()
File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/apps/contacts/regions/settings_form.py", line 99, in tap_sync_friends
expected.element_present(*self._sync_friends_locator))
File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 10.2 seconds



Environmental Variables:
Device firmware (base) 	L1TC100118D0
Device firmware (date) 	29 Jun 2015 21:10:03
Device firmware (incremental) 	eng.cltbld.20150629.170951
Device firmware (release) 	4.4.2
Device identifier 	flame
Device memory 	219772 kB
Device serial 	1d9e570a
Device uptime 	0 days 0 hours 2 minutes 10 seconds
Gaia date 	29 Jun 2015 14:29:00
Gaia revision 	27fe0f4261e3
Gecko build 	20150629134017
Gecko revision 	c26dbd63604d
Gecko version 	42.0a1

Reproducible manually: YES

Repro frequency: 5/5
(Assignee)

Comment 1

4 years ago
(In reply to Oliver Nelson [:oliverthor] from comment #0)
> Description:
> test_facebook_sync_contacts.py is no longer a viable test due to bug
> 1175455: the import facebook contacts button has been removed from settings.
> Following the meta bug 1173011 indicates to me that this feature may return
> with a new API, so advising that this case becomes a permafail while this is
> sorted out.

I would say this test (and test_unlink_facebook.py btw) can be removed then, since this feature has been removed.
According to bug 1173011, comment 1, it could also be removed for v2.2.

When the new Facebook implementation gets checked in, then I guess we need to write new tests for that.
Or perhaps you think it's better to disable these tests and rewrite them as soon as the new Facebook implementation gets checked in?
Assignee: nobody → martijn.martijn
Blocks: 1175455
(In reply to Martijn Wargers [:mwargers] (QA) from comment #1)
> I would say this test (and test_unlink_facebook.py btw) can be removed then,
> since this feature has been removed.
In today's Comms triage, I heard from the manager that Facebook will be removed entirely. I agree, let's remove this test. If one day, Facebook is back, we'll be able to get this test back from the git history.

> According to bug 1173011, comment 1, it could also be removed for v2.2.
As 2.2 is now feature complete, I'm not sure we'll change the 2.2 codebase for that.
(Assignee)

Comment 3

4 years ago
Created attachment 8628212 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/30774

test_unlin_facebook.py still works for now, actually.
Attachment #8628212 - Flags: review?(jlorenzo)
The link button used in this test will be removed in bug 1178891.
Attachment #8628212 - Flags: review?(jlorenzo) → review+
See Also: → bug 1178891
Comment hidden (typo)
Note: No need to delete test_unlink_facebook.py in this bug. I asked to delete it when the button will disappear (see bug 1178891 comment 1).
(Assignee)

Comment 7

4 years ago
Merged: https://github.com/mozilla-b2g/gaia/commit/f729f520cacb4eaced4aa14f05fe238e85adcc93
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.