Add 'tsz' and 'cak' locales to the Fennec build

VERIFIED FIXED

Status

defect
VERIFIED FIXED
4 years ago
a year ago

People

(Reporter: gueroJeff-parental, Assigned: rail)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(firefox41 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

We need to add 'tsz' to the Fenenc Aurora l10n builds.

PS: to be clear to the localization team, this bug is handled by Mozilla staff.
(Assignee)

Comment 1

4 years ago
Posted patch tsz.diff (obsolete) — Splinter Review
Assignee: nobody → rail
Attachment #8627852 - Flags: review?(l10n)

Updated

4 years ago
Depends on: 1178928

Updated

4 years ago
Duplicate of this bug: 1178944
Comment on attachment 8627852 [details] [diff] [review]
tsz.diff

lgtm, r=me.

We'll want to wait for the actual repos to not run into odd situations.
Attachment #8627852 - Flags: review?(l10n) → review+
(Assignee)

Comment 4

4 years ago
Posted patch cak+tsz.diffSplinter Review
Combined with bug 1178930 now
Attachment #8627852 - Attachment is obsolete: true
Attachment #8628067 - Flags: review?(l10n)
Comment on attachment 8628067 [details] [diff] [review]
cak+tsz.diff

Review of attachment 8628067 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, thanks.
Attachment #8628067 - Flags: review?(l10n) → review+
(Assignee)

Comment 6

4 years ago
Comment on attachment 8628067 [details] [diff] [review]
cak+tsz.diff

This is an aurora-only patch, enabling 2 Android locales.
[Risks and why]: It affects Android l10n repacks only.
Attachment #8628067 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 7

4 years ago
The repos look ready, just waiting for a+.
(Assignee)

Updated

4 years ago
Summary: Add 'tsz' to the Fennec build → Add 'tsz' and 'cak' locales to the Fennec build
Comment on attachment 8628067 [details] [diff] [review]
cak+tsz.diff

Approving the uplift to moz-aurora. Patch looks simple and blessed by Axel.
Attachment #8628067 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1178930
Awesome! Thank you ritu and rail.

Added to the whiteboard to be sure the patch gets checked in this afternoon.
Whiteboard: [checkin-needed-aurora]
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [checkin-needed-aurora]
I found a tsz build this morning (which is beautiful!), but no cak build. Could you look into the build logs to see why cak was skipped/aborted?

Thanks!
See the two errors reported on the dashboard, https://l10n.mozilla.org/teams/cak, unescaped (\!) quotes in sync_strings.dtd:

Quotes in Android DTDs need escaping with \" or \u0022, or put string in apostrophes. at line 20, column 64 for sync.subtitle.pair.label
Quotes in Android DTDs need escaping with \" or \u0022, or put string in apostrophes. at line 20, column 85 for sync.subtitle.pair.label
I just went in and fixed those.

Would those be critical enough for a build to fail?
Princess Android being Princess, sadly. The apkbuilder dies for this.

FYI, https://treeherder.mozilla.org/#/jobs?repo=mozilla-aurora&exclusion_profile=false&filter-searchStr=night shows the builds.
Both builds are now available. Thank you all
Status: RESOLVED → VERIFIED
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.