Patch fixing release build of JavaScript debugger (console)

VERIFIED FIXED

Status

Other Applications
Venkman JS Debugger
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Jörg Schaible, Assigned: Robert Ginda)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
jsdb cannot be build with current jsdb.mak. Any call to mk "BUILD_OPT=1" will 
result in an error of the make file. Attachment provided with a unified diff.
(Reporter)

Comment 1

16 years ago
Sorry file attachment does not work neither with IE6 nor mozilla 0.9.5
Bugzilla claims diff file to be empty every time.

===================== jsdb.diff =====================
--- jsdb.mak    Thu Nov  5 09:57:22 1998
+++ jsdb.new.mak        Thu Jan  3 13:11:50 2002
@@ -62,19 +62,19 @@
 
 $(OBJ)\js32.dll :
     @cd ..\..\src
-    @nmake -f js.mak CFG="js - Win32 Debug"
+    @nmake -f js.mak CFG="js - Win32 $(OBJ)"
     @cd ..\jsd\jsdb
     @echo Copying dll from js/src
     @copy $(JSSRC)\$(OBJ)\js32.dll  $(OBJ)  >NUL
-    @copy $(JSSRC)\$(OBJ)\js32.pdb  $(OBJ)  >NUL
+    @if "$(OBJ)" == "Debug" copy $(JSSRC)\$(OBJ)\js32.pdb  $(OBJ)  >NUL
 
 $(OBJ)\jsd.dll :
     @cd ..
-    @nmake -f jsd.mak JSD_THREADSAFE=1
+    @nmake -f jsd.mak JSD_THREADSAFE=1 BUILD_OPT=$(BUILD_OPT)
     @cd jsdb
     @echo Copying dll from js/jsd
     @copy $(JSD)\$(OBJ)\jsd.dll  $(OBJ)  >NUL
-    @copy $(JSD)\$(OBJ)\jsd.pdb  $(OBJ)  >NUL
+    @if "$(OBJ)" == "Debug" copy $(JSD)\$(OBJ)\jsd.pdb  $(OBJ)  >NUL
 
 dlls : $(OBJ)\js32.dll $(OBJ)\jsd.dll
 
@@ -95,8 +95,8 @@
 
 deep_clean: clean
     @cd ..\..\src
-    @nmake -f js.mak CFG="js - Win32 Debug" clean
+    @nmake -f js.mak CFG="js - Win32 $(OBJ)" clean
     @cd ..\jsd\jsdb
     @cd ..
-    @nmake -f jsd.mak clean
+    @nmake -f jsd.mak clean BUILD_OPT=$(BUILD_OPT)
     @cd jsdb
=====================================================
Summary: Patch fixing release build of JavaScript debugger (console) → Patch fixing release build of JavaScript debugger (console)

Comment 2

16 years ago
*** Bug 117906 has been marked as a duplicate of this bug. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: patch
(Assignee)

Comment 3

16 years ago
-    @copy $(JSSRC)\$(OBJ)\js32.pdb  $(OBJ)  >NUL
+    @if "$(OBJ)" == "Debug" copy $(JSSRC)\$(OBJ)\js32.pdb  $(OBJ)  >NUL

Why only copy into a OBJ specfic subdirectory for Debug builds?
Status: NEW → ASSIGNED
(Reporter)

Comment 4

16 years ago
The .pdb files are only generated if the linker's option /debug is set. This is 
only true for debug builds (see BUILD_OPT settings). Since copy fails (and 
therefore the complete build) for the non existing file the copy action is only 
valid building the debug version.

As an alternative you could build the exe's and dll's always with the /debug 
switch of the linker, since it has no influence on the resulting exe or dll 
(all debug info is in the .pdb), but this would result in changes in all 
dependent make files. Advantage: Even for release builds you would have a 
visible call stack as it is available for the system libraries installing the 
debug symbols.
(Assignee)

Comment 5

16 years ago
Oh, I see.  Patch checked in as is, thanks for the diff :)
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Verify checked in
Status: RESOLVED → VERIFIED
QA Contact: rginda → caillon
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.