Closed Bug 1179076 Opened 5 years ago Closed 3 years ago

Changing a bookmark's keyword doesn't remove keyword from database

Categories

(Toolkit :: Places, defect, P2)

39 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1150678

People

(Reporter: bugs, Unassigned)

References

Details

(Keywords: regression)

If you change a bookmark's keyword, the previous keyword remains in the database, and you can no longer set that keyword on any bookmark. If you remove the keyword entirely instead of changing it to something else, the keyword is removed from the database as expected. This occurs in a fresh profile on 39 beta, 40 aurora, and 41 nightly. I haven't tested the release channel, but I can't recall this happening during my time on 38 beta.
Component: Bookmarks & History → Places
Product: Firefox → Toolkit
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
I think I may be experiencing the same keyword issue with v39.0 release.

I cannot use certain keywords, even though they are unassigned.  It is possible that they were assigned before; I do not know.

For example, when I try to change a keyword from 'ampl' to 'amp', Firefox refuses to change the keyword, even though the keyword 'amp' is not currently in use.

Hopefully whatever fix is implemented will clean up the database so these keywords can be used again.
bug 1150678 may fix this too.
Depends on: 1150678
Priority: -- → P2
Duplicate of this bug: 1232769
This serious bug is still present in Firefox 43.0.

This bug renders Firefox keywords unreliable.  Simply creating a bookmark with a common keyword, and then deleting that bookmark makes that keyword never available in Firefox again (until this bug is fixed).

When the user attempts to assign that keyword to a new bookmark, it causes the Firefox UI to not align with what will really happen when that keyword is used.

Keywords are part of the basic functionality of Firefox.  Fixing this bug really needs to be made a priority.
I have seen this popping up several times over the months on reddit (/r/firefox/) and have just seen another affected user (I personally am affected by this), but have seen no developmental efforts.
You may one keyword and that keyword is forever lost to you for other bookmarks and from autocomplete.

Can we get a status update?
What are the next steps?
I've found a workaround for this issue.
1. Make sure Firefox is closed,
2. Open ~firefox_profile/places.sqlite (e.g. with sqliteman),
3. Table moz_keywords contains all the keywords, just find the one that is corrupted and remove it.
  (e.g. with "DELETE FROM moz_keywords WHERE keyword = XYZ" where XYZ is the culprit keyword)
Mateusz, that's basically what I do every time I change a keyword.  It's a PITA workaround, but it does workaround the bug in Firefox.

Note that I'm not sure if you can use sqliteman, however.  The last time I checked, it used a version of SQLite that was too old to work with Firefox's current implementation of places.sqlite.
Bug still present in Firefox 47.0.1

Is anyone willing to work on this?
Thanks for the workaround Mateusz, using sqliteman I managed to fix a couple of keywords I couldn't assign previously. Rather annoying having to do this any time I wish to change the URL of a keyword.
as a workaround, you can rather remove the old bookmark with the keyword, and then create a new one with the new keyword.
could you please check if this is now fixed by bug 1150678?
Based on the other similar bugs I'm assuming this is WFM now.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150678
I believe I'm being affected by this bug. I'm trying to simply set up search bookmarks to search Reddit with the "!r" keyword and to search the Arch Linux package repositories with "!pac". However, whenever I set these keywords, they are immediately removed / blanked out. If I try setting them to something else, then it saves properly, but I don't want the keywords to be anything else... "!r" and "!pac" just get removed.

I'm not sure what I can even do to fix this. I have thousands of bookmarks, but as far as I know the only ones that ever had keywords were the ones in my "Search Engines" folder. I already tried deleting every single bookmark I had in my "Search Engines" folder, and tried recreating them all with their keywords. It still won't let me use "!r" and "!pac" as keywords though.

This is an extremely frustrating issue.
Elena, have you tried the workaround by  Mateusz in comment 6 (i.e. edit places.sqlite and remove any remnant entries with keywords 'r' and 'pac')? It solved the issue for me.
(In reply to Elena from comment #13)
> I believe I'm being affected by this bug.

Which Firefox version?
Most keywords bug are fixed from FF 51 and greater.
I'm running Firefox 45.5.1. I tried the suggestion of using sqliteman, but unfortunately my "moz_keywords" table only contains the working keywords that I have set up. The broken ones, "!r" and "!pac" are nowhere to be found in that table. I had a look around the other tables and I couldn't find any mention of them elsewhere either. Is my profile just doomed?
I am having the same problem today with Nightly 53.0a1 (2017-01-19)
> I am having the same problem today with Nightly 53.0a1 (2017-01-19)

Nevermind
You need to log in before you can comment on or make changes to this bug.