Closed Bug 1179173 Opened 7 years ago Closed 7 years ago

[B2G] Add devices information in audio volume event

Categories

(Firefox OS Graveyard :: AudioChannel, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1179181

People

(Reporter: alwu, Unassigned)

References

Details

In Bug1170117, we want to implement the separate volume control setting for different output device. 

However, we can't get the consistent volume when we change the device after shutdown the phone. When we start/reboot the phone, we would get the volume value from the cache, and then send the volume event to Gecko in order to set the hardware volume. Because we only cache the volume value by types, we don't cache value by devices.

For example,
1. Use primary output(speaker/receiver), and set the volume index to 5.
2. Use headphone, and set the volume index to 10. (store volume 10 to cache)
3. Shutdown the phone 
4. Unplug the headphone
5. Restart the phone 

Expected.
6. Volume value is 5 (because we use the primary output now)

Actual.
6. Volume value is 10 (get value from cache, and get 10)

---
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1179181
You need to log in before you can comment on or make changes to this bug.